## Contents

### Change history
CHANGE HISTORY: 4

### Overview
Overview: 5

- System requirements: 5

### Understanding the application
Understanding the application: 6

- Understanding the basics: 6
- Licensing Solution Composer Agent: 8
- Getting started: 9
- Checking the version of the Embedded Solutions Framework: 10
- Configuring the time stamp format: 11

### Using the application
Using the application: 12

- Step 1: Creating projects and adding tasks and branches: 12
- Step 2: Validating solutions (optional): 14
- Step 3: Simulating solutions (optional): 15
- Step 4: Saving projects: 15
- Step 5: Deploying solutions: 16

### Sample solution
Sample solution: 18

- Scenario 1: Scanning W-4 forms to a corporate FTP site: 18
- Scenario 2: Submitting loan applications and sending e-mail confirmations: 19

### Troubleshooting
Troubleshooting: 24

- Deployed solutions do not appear on the printer: 24
- Printer hard disk is missing: 24
- Printer hard disk is full: 25
- Cannot send jobs to the remote printer: 25
- OCR or MRC does not work properly: 25
- Scan to FTP does not work properly: 25
- Scan to Fax or fax actions cause the solution to fail: 25
- Scan to E-mail or e-mail actions cause the solution to fail: 26
- Scan to E-mail fails to send an e-mail: 26
Frequently asked questions................................................................. 27
Notices................................................................................................. 29
Glossary............................................................................................... 33
Index................................................................................................. 34
Change history

February 2020
• Added support for SFTP.
• Added information on Timestamp Format.

September 2017
• Added information on SMBv3 Compatibility Mode.

January 2016
• Initial document release for multifunction products with a tablet-like touch-screen display.
• Added support for the Windows 10 operating system.
Use the application to build custom workflow solutions for multifunction products running the Solution Composer Agent. These solutions can range from one- or two-step processes to more complex workflows involving branching, index files, and multiple user prompts.

Solutions built using Solution Composer can be deployed directly to a printer from the application. They can also be saved as a file that can be loaded to a printer from its Embedded Web Server.

This document provides instructions on how to create solutions and troubleshoot common problems.

This document is intended for use by personnel who purchased Solution Composer.

**System requirements**

- Microsoft® Windows® operating system: Windows 10, Windows 8.1, Windows 8, or Windows 7
- Java version 1.6 or later
- 1GB or more of RAM
- 1.8GHz or faster processor
- PDF reader (for Help files)
Understanding the application

Understanding the basics

Use the following panes of the main application window to select and configure tasks that make up solutions:

- **Task Library**—The location of actions and prompts used to form the sequence of events in a solution. This library includes four categories: User Prompts, Actions, Index Files, and Confirmations.
- **Solution Design**—Arrange tasks and determine the sequence of events in a solution.
- **Task Properties**—Set properties for each task in the Solution Design pane.

Other components for building solutions include:

- **Simulator**—A way to check the basic look, flow, and syntax of a project.
- **Solution Packages**—Deployed projects that are installed on printers running Solution Composer Agent.
- **Solution Composer Agent**—A licensed embedded application that lets you install solutions that are built using Solution Composer and run them on printers. For more information on licensing the application, see “Licensing Solution Composer Agent” on page 8 or contact your Lexmark representative.

Understanding the Task Library

All solutions built using Solution Composer are based on two types of tasks:

- **User Prompts**—Activities that the user does
- **Actions**—Activities that the printer does

Other types of tasks are:

- **Index Files**—A custom index file for user-defined content that is saved in an FTP or network location
- **Confirmations**
User Prompt tasks

- **Message**—Show a message on the printer display. This prompt requires no user input.
- **Multiple Choice**—Prompt users to select from a list of options. This prompt is also used as a source for the Branch task.
- **Numeric Entry**—Prompt users to enter a numeric value, such as a PIN.
- **Text Entry**—Prompt users to type a text string, such as a user name.

Action tasks

- **Branch**—Split the printer solution workflow into two or more branches based on user selection from the previous Multiple Choice prompt.
- **Copy**—Print scanned files at the printer.
- **LDAP Lookup**—Retrieve LDAP information using the printer Address Book Setup.
- **Multi Send**—Scan a file once and send the scanned files to multiple destinations. This action supports e-mail, fax, FTP, copy, remote printer, secure e-mail, network, LDD, LDIC, Perceptive Content™, and ReadSoft destinations.
- **Print From Network**—Print saved files in a specified network location.
- **Scan to E-mail**—Send scanned files to specified e-mail addresses.
- **Scan to FTP**—Save scanned files to a specified FTP destination.
- **Scan to Fax**—Send scanned files to specified fax destinations.
- **Scan to Fax Server Folder**—Use fax information to save scanned files to a specified network location.
- **Scan to LDD**—Send scanned files to an LDD server.
- **Scan to LDIC**—Send scanned files to an LDIC server.
- **Scan to Network**—Save scanned files to a specified network location.

Note: This feature is available only in some printer models.

- **Scan to Perceptive Content**—Send scanned files to a Perceptive Content Server.
- **Scan to ReadSoft Online**—Send scanned files to ReadSoft.
- **Scan to Remote Printer**—Send scanned files to a specified remote printer.
- **Scan to Secure E-mail**—Send scanned files to specified e-mail addresses with authentication or encryption.

Index File tasks

- **Index File to FTP**—Save a custom index file for user-defined content to a specified FTP destination.
- **Index File to Network**—Save a custom index file for user-defined content to a specified network location.

Confirmation tasks

- **E-mail Confirmation**—E-mail a message text to specified e-mail addresses.
- **Print Confirmation**—Print a message text at the printer.
- **Secure E-mail Confirmation**—E-mail a message text to specified e-mail addresses with authentication or encryption.
Licensing Solution Composer Agent

Solution Composer Agent is offered with a 30-day trial license that lets you deploy solutions built using Solution Composer. To continue using the Solution Composer Agent on your printers after the trial period, you need a license.

For more information, contact your Lexmark representative.

Obtaining a license

**Note:** This feature is available only in some printer models.

1. Open a Web browser, and then type the printer IP address.
   
   **Note:** Locate the IP address in the TCP/IP section of the Network/Ports menu.

2. Click **Settings** or **Configuration**.

3. Depending on your printer model, do one of the following:
   - Click **Apps** > **Apps Management**.
   - Click **Device Solutions** > **Solutions (eSF)**.
   - Click **Embedded Solutions** > **Install**.

4. Click **System**, and then take note of the host ID (serial number).
   
   **Note:** Record only the string that appears after **Serial=**.

5. Contact your solution provider, and then provide the host ID to obtain the license file.

Installing the license

**Note:** This feature is available only in some printer models.

1. Open a Web browser, and then type the printer IP address.
   
   **Note:** Locate the printer IP address from the printer home screen.

2. Click **Settings** or **Configuration**.

3. Depending on your printer model, do one of the following:
   - Click **Apps** > **Apps Management**.
   - Click **Device Solutions** > **Solutions (eSF)**.
   - Click **Embedded Solutions**.

4. Under Installed Solutions, click **Solution Composer Agent** > **License** > **Update License** > **Install**.

5. Browse to the license file.

   **Note:** Make sure that **Local** is selected.

6. Click **Install**.
Getting started

You can build solutions in Solution Composer using the following process:

1. Add tasks.
2. Configure the properties for each task.
3. Validate the solution (optional).
4. Simulate the solution to check its overall flow (optional).
5. Deploy the solution to an enabled printer device (includes naming and configuring solution properties).

Arranging tasks

When creating a workflow, arrange tasks in the order in which they are needed in the finished solution. For example, let users log in before using the Scan to FTP task so that their user name is used as a variable. Arrange the workflow so that the Text Entry user prompt appears before the Scan to FTP task. There are two ways to arrange tasks:

- Plan the flow of actions and prompts, and then add them to the workflow in order in the Solution Design pane.
- Drag workflow tasks already inside the Solution Design pane to arrange them.

Configuring task properties

Use the Task Properties pane to configure various attributes for each task you add to a workflow. Configuring task properties may involve filling in a text field, selecting options from a drop-down menu, or inserting predefined variables. The Task Properties pane consists of the following data input options:

- Text boxes
  - Single-line text boxes—Specify values in these boxes by clicking anywhere in the text field and typing.
  - Multi-line text boxes—Specify values in these boxes by clicking the ellipsis button and then typing text in the dialog box that appears.

  Note: Text boxes can also be populated with one or more variables. Insert these variables by themselves or embedded within text. For more information about using variables, see the following section.

- Drop-down boxes—Select from a set of choices specific to a particular field.
- Check boxes—Enable or disable a specific feature.
- Numeric entry boxes—Allow customized numeric entries.

Notes:

- Asterisks indicate required fields.
- Solutions cannot be deployed until all required fields are populated. However, you can save solutions without populating all required fields.

Using variables

You can add variables to any task property field where text can be typed. Variables represent dynamically updated data based on conditions at the time the solution is run. For example, if you select a system variable such as Printer IP Address, then that information is gathered from the printer when the solution is run.
Variables can also come from previously added workflow tasks, such as a user prompt. For example, your workflow has a Text Entry user prompt asking users to enter their credentials. The Response variable from that Text Entry prompt can be selected as a variable for the User Name property in the Scan to FTP task.

To view the list of variables available for a particular property, do either of the following:

- Click inside the text entry field, and then click \{N\} on the Task Properties toolbar.
- Right-click inside the text entry field, and then select Insert Variable.
- Click the ellipsis button next to a field to open the text box, and then select the variables from the Variable Selection section by double-clicking them.

### Exporting solution configurations

1. Obtain the printer IP address. Do either of the following:
   - Locate the IP address on the top or upper-left corner of the printer home screen.
   - View the IP address in the Network Overview section or in the TCP/IP section of the Network/Ports menu.
2. Open a Web browser, and then type the printer IP address.
3. Depending on your printer model, do one of the following:
   - Click Export Configuration > All Settings.
   - Click Settings or Configuration, and then click Import/Export > Export Embedded Solutions Settings File.
4. If necessary, repeat step 2 through step 3 for every new workflow.

### Adding a bar code template

Add bar codes to Solution Composer from the Bar Code Template Management dialog box. For more information on how to create and manage bar code templates, see the Bar Code Discovery Administrator’s Guide.

Before you begin, make sure to export the solution configurations.

1. From Solution Composer, click Tools > Bar Code Template Management.
2. Load templates from a file, or retrieve templates from a printer by typing the printer IP address.
3. If necessary, click Apply.

Note: Reload the workflow to retrieve the bar code template.

### Checking the version of the Embedded Solutions Framework

1. Access the Embedded Web Server.
2. Depending on your printer model, do either of the following:
   - Click Reports > Device Settings. In the Embedded Solutions section, note the value associated with "Framework =.”
   - Click Apps > App Framework Configuration.
Note: To view the complete list of supported printers for each version of the Embedded Solutions Framework, see the Readme file.

Configuring the time stamp format

This setting is available only for the following Actions:

- Scan to E-mail
- Scan to FTP
- Scan to Network
- Scan to Secure E-mail
- Multi Send that uses the E-mail, FTP, Network, or Secure E-mail destination.

1 In the Task Properties pane of a supported action, select Append time stamp.

2 In the Timestamp Format field, type the format.

Note: To view the complete list of supported date and time formats, see the Readme file.
Using the application

Step 1: Creating projects and adding tasks and branches

1. Do either of the following:
   - Click File > New.
   - From the toolbar, click 📜.

2. From the Task Library pane, select a task category, and then double-click a task icon.
   **Notes:**
   - You can also drag a task category into the Solution Design pane.
   - Task names are optional and are used for reference only.
   - To rename a task in the Solution Design pane, double-click its name and then type a new name.

3. From the Task Properties pane, configure the task properties.
   **Notes:**
   - To access the task properties, click its icon in the Solution Design pane.
   - If you add a task to the workflow before correctly configuring the required properties of an existing task, then ⚠️ appears next to the existing task. Mouse over the task icon to show a dialog box listing the configuration problems.

Deleting tasks from a workflow

From the Solution Design pane, do either of the following:
- Select the task, and then press **Delete** on your keyboard.
- Right-click the task, and then select **Delete Task**.
Adding branches to a workflow

Use Branch to split your printer solution into two or more branches based on a condition, with each branch consisting of one or more tasks.

Notes:

- The Multiple Choice prompt is required in the workflow. Configure the settings to allow only one selection.
- A branch can be nested up to 3 layers. Each nested branch can have up to 10 branches.
- A branch must be the last task in the layer where it belongs. It cannot return to the previous task flow, and you can no longer add tasks after the Branch action. Alternatively, remaining tasks are added within the branches.

1 From the Task Library pane, under Actions, double-click Branch.

2 In the Branch Source Selection dialog box, select a variable to use in creating branch assignments or conditions.
   
   Note: To change your selected variable, from the Task Properties pane, click Change Branch Source.

3 Double-click Branch in the Solution Design pane, or click on the Branch icon.

Notes:

- By default, the task has two empty branches. Branch 1 is highlighted as the active design area. Double-click tasks from the Task Library to add them to Branch 1.
- To make another branch the active design area, click the branch you want to activate.
- You can add up to 10 branches. To add a branch, click .
- To provide a custom name for a branch, double-click the default branch name (for example, Branch 1).
- A Branch task must contain at least two branches. If there are only two branches, then deleting one of them adds an empty branch.
4 From the Task Library pane, select a task category, and then do either of the following:
   • Click the branch in the Solution Design pane that you want to add a task to, and then double-click a task icon.
   • Drag a task icon into any branch in the Solution Design pane.

To delete a task from a branch, do either of the following:
   • Select the task, and then press Delete on your keyboard.
   • Right-click the task, and then select Delete Task.

5 Continue adding tasks until each branch is populated with a workflow.

Notes:
   • You can add a Branch task to one or more branches of an existing branch. You can create up to three layers of nested branches, and the branch must be the last task within any given branch.
   • Task names are optional and are used for reference only.
   • To rename a task in the Solution Design pane, double-click its name and then type a new name.

6 Configure the properties for each task in each branch. Select a task from a branch in the Solution Design pane, and then configure the properties in the Task Properties pane.

   Note: If you add a task to a branch before correctly configuring the required properties of an existing task, then ! appears next to the existing task. Mouse over the task icon to show a dialog box listing the configuration problems.

7 After creating workflows for each branch, assign the choices from the Multiple Choice prompt to a branch.
   a Click the Branch icon.
   b From the Task Properties pane, under Branch Assignment, click the Unassigned drop-down menu on the first condition.
   c Select the branch to which the workflow proceeds when the user selects the choice from the Multiple Choice prompt.
   d Repeat the steps to assign a branch to every condition or choice in the Multiple Choice prompt.

   Note: To return to the main Solution Design pane, click on the Branch icon.

**Step 2: Validating solutions (optional)**

Solution Composer projects are saved and deployed as solution packages. Validate a solution before saving or deploying it to identify and correct errors while you are still working on the solution. Solutions are automatically checked for errors when they are deployed.

1 Do either of the following:
   • Click Tools > Validate.
   • From the toolbar, click ✔.

2 In the Validation Summary dialog box, take note of any errors, and then close the dialog box.

3 If there are any errors, then correct the errors and validate again.
Step 3: Simulating solutions (optional)

Before saving or deploying a solution in Solution Composer, use Simulate to check the basic look, flow, and syntax of the solution. Simulate can approximate how a solution will look when it is running on a device. It cannot show exactly how the solution will look on a specific device model.

Notes:

- Make sure that all task properties in your solution are configured correctly so that you can run the simulation.
- If certain task property values are not available during the simulation, then a notification message appears.

Simulating solutions

1. Do either of the following:
   - Click `Tools > Simulate`.
   - From the toolbar, click `Simulate`.
2. Click the solution icon.
3. Navigate through the screens and respond to user prompts.
   Notes:
   - Use the computer keyboard to type data for prompts that require text input.
   - You cannot modify task properties settings from the Details pane. If you want to modify settings, then close the Simulator dialog box, and then modify the settings from the Task Properties pane.
4. Click `Next` on the final screen to return to the home screen.

Step 4: Saving projects

You can save Solution Composer projects as .lwfs files that can be opened and edited later using Solution Composer. These files represent saved work, not completed solutions, and .lwfs files cannot be deployed to a printer device.

Projects can be saved with or without a password. When you save projects that are not protected by a password, a generic encryption key is used. However, any Solution Composer user can open these projects. To restrict access to a project, save the file using the `Save As ... with Password` option.

Saving projects without a password

1. Do either of the following:
   - Click `File > Save`.
   - From the toolbar, click `Save`.
   Note: If you are deploying to a file, then use the Save As dialog box to name and save the file to the location you want.
2. Browse to the location where you want to save the file, and then name the file.
3. Click `Save`. 
Saving projects with a password

1 Do either of the following:
   - Click File > Save As ... with Password.
   - From the toolbar, click the arrow to the right of , and then select Save As ... with Password.
2 Browse to the location where you want to save the file, and then name the file.
3 Click Save.
4 Type a password in the dialog box, and then click OK.
   When you open the file, you are prompted for this password.

Step 5: Deploying solutions

You can deploy Solution Composer projects in two ways: directly to printers from Solution Composer or as an installation file.

Deploying directly to a printer

Notes:
- This feature is available only in some printer models.
- This method requires the printer IP address or host name.

1 Do either of the following:
   - Click Tools > Deploy Solution to Printer.
   - From the toolbar, click .
2 In the Deploy Solution to Printer dialog box, fill in the required fields.
   Note: You can deploy solutions to one printer at a time. Handle multiple printers separately.
3 Deploy the solution.
   Notes:
   - All required files must be populated to deploy the solution.
   - If you are deploying to a file, then use the Save As dialog box to name and save the file to the location you want.
   - If you are deploying directly to a printer, then note the status indicator. A confirmation message shows whether the deployment was successful or not.

Deploying to a file

Solutions can be saved as .lwfd files. These files are installed using the Embedded Web Server on printers that have a running Solution Composer Agent. If a network is unavailable for direct deployment, or if you want to save the solution package for installation on multiple printers, use this option.

1 Click Tools > Deploy Solution to File.
2 In the Deploy Solution to File dialog box, fill in the required fields.
3 Obtain the printer IP address. Do either of the following:
   • Locate the IP address on the top or upper-left corner of the printer home screen.
   • View the IP address in the Network Overview section or in the TCP/IP section of the Network/Ports menu.

4 Open a Web browser, and then type the printer IP address.

5 Depending on your printer model, do one of the following:
   • Click Apps > Install a New App.
   • Click Settings > Apps > Apps Management > Install a New App.
   • Click Settings > Device Solutions > Additional Solutions > Install.
   • Click Settings or Configuration, and then click Embedded Solutions > Install.

6 Browse to the solution file.

7 Click Install or Start.

Solution properties
The solution properties define the basic information about a solution both on the printer and from the printer Embedded Web Server.

• **Name**—Used to represent the solution in the list of installed solutions on the printer Embedded Web Server.
   
   **Note:** To avoid overwriting the installed solution, make sure that the deployed solution has a different name or has the latest version number for the solution.

• **Version**—Used as a reference only. To avoid overwriting the installed solution, make sure that the deployed solution has a different name or has the latest version number for the solution.
   
   **Note:** Only numbers and periods can be used in the Version field. Version numbers cannot start with a period or contain two or more consecutive periods.

• **Image**—Use a PNG, GIF, JPEG, or BMP file to represent the application on the control panel.
   
   **Notes:**
   – Images are resized to fit the icon.
   – If no image is specified, then a default icon is used for the customer solution.

• **Description**

Support info
Solutions built using Solution Composer may require technical support. Fill in the support information completely and correctly.
To access support information from the printer Embedded Web Server, click Application > Solution Composer > [solution name].
Sample solution

The following scenarios show how to use Solution Composer to build solutions that accomplish specific tasks.

Scenario 1: Scanning W-4 forms to a corporate FTP site

In this scenario, a user creates a solution that lets franchise retail stores scan W-4 forms for new employees to a corporate FTP site. The user scans the form into a single file, which is then saved on the corporate FTP site with a file name that users cannot change. The solution shows a message on the printer display reminding the user to file the W-4 form in the employee personal file.

Note: For more information on creating a solution, see “Using the application” on page 12.

Creating the solution

1. Do either of the following:
   - Click File > New > Printer.
   - From the toolbar, click the arrow beside , and then select Printer.

2. From the Task Library pane, under User Prompts, double-click Message, and then give it a descriptive name. For example, Load forms.

3. From the Task Properties pane, configure the Message prompt.
   a. In the Message field, click the ellipsis button.
   b. In the Message dialog box, type a message reminding users to load a W-4 form on the scanner glass or into the automatic document feeder (ADF).
   c. From the Justify menu, select Center.

4. From the Task Library pane, under Actions, double-click Scan to FTP, and then give it a descriptive name. For example, Scan document.

5. From the Task Properties pane, configure the Scan to FTP action.
   a. Under FTP Connection, clear Prompt at Runtime to disable changing settings when the solution is running.
   b. Select Use SFTP.
      Note: This setting is also available in the FTP destination for the Multi Send action.
   c. Provide the URL and credentials necessary to connect to the FTP site.
   d. Under Output, in the Scan File Name field, type w4_from_mfp_.
   e. Right-click inside the Scan File Name field, and then select Insert Variable.
   f. In the Variable Selection dialog box, click System Variables > Printer IP Address > OK.
   g. In the Scan File Name field, type an underscore (_) after the Printer IP Address variable.
   h. Under Scan Settings (Basic), in the Original Sides (Two-Sided) menu, select Duplex.

6. From the Task Library pane, under User Prompts, double-click Message, and then give it a descriptive name. For example, File completed.

7. From the Task Properties pane, use the Message field to remind users to file the W-4 form properly after scanning.
8 Check the solution for errors. Do either of the following:
   • Click **Tools > Validate**.
   • From the toolbar, click ✓.

9 If there are any errors in the Validation Summary dialog box, then correct the errors and validate again.

10 Check the overall flow of the solution. Do either of the following:
   • Click **Tools > Simulate**.
   • From the toolbar, click 📝.

11 From the Tools menu, deploy the solution. Do either of the following:
   • **Deploy Solution to Printer**—Install the solution directly on a printer.
     
     **Notes:**
     − This feature is available only in some printer models.
     − To deploy directly to printers, make sure that the printer is on the same network as the Solution Composer Agent. You can use the IP address or host name of the printer.
   • **Deploy Solution to File**—Create a solution file that can be installed later on a printer.

**Sample flow when using the solution**

1 From the printer home screen, the user touches the icon for the solution.

2 The printer prompts the user to load the W-4 form on the scanner glass or into the ADF tray.

3 The user loads the document, and then touches **Next**.

4 The printer shows a message while it scans the document to the appropriate FTP folder.

5 The printer shows the custom message reminding the user to file the W-4 form in the employee’s folder.

6 The user touches **Next** and returns to the home screen.

**Scenario 2: Submitting loan applications and sending e-mail confirmations**

In this scenario, a user creates a solution for submitting loan applications. First, the solution prompts the user to select the type of bank loan. Next, the solution scans the required documents to a specified network folder. Lastly, the solution sends a notification to a specified e-mail address.

**Note:** For more information on creating a solution, see “Using the application” on page 12.

**Creating user prompts**

1 Do either of the following:
   • Click **File > New > Printer**.
     • From the toolbar, click the arrow beside 📞, and then select **Printer**.

2 From the Task Library pane, under User Prompts, double-click **Message**, and then give it a descriptive name. For example, **Welcome Screen**.
3 From the Task Properties pane, configure the Message prompt.
   a Under General, in the Title field, type Loan Application.
   b In the Message field, click the ellipsis button.
   c In the Message dialog box, type a welcome message, and then click OK.
   d From the Justify menu, select Center.

4 From the Task Library pane, under User Prompts, double-click Text Entry, and then give it a descriptive name. For example, Name.

5 From the Task Properties pane, configure the Text Entry prompt.
   a Under General, in the Prompt field, type Enter full name:
   b In the Error Msg field, click <Use Printer Setting>, and then click the ellipsis button.
   c In the Error Msg dialog box, type Please enter your full name., and then click OK.
   d Under Restrictions, select Text Visible.
   e Set Min Length to 1 and Max Length to 50.

6 From the Task Library pane, under User Prompts, double-click Numeric Entry, and then give it a descriptive name. For example, Age.

7 From the Task Properties pane, configure the Numeric Entry prompt.
   a Under General, in the Prompt field, type Enter your age:
   b In the Error Msg field, click <Use Printer Setting>, and then click the ellipsis button.
   c In the Error Msg dialog box, type Reminder: Loan applicants must be between 18 and 60 years old., and then click OK.
   d Under Restrictions, select Text Visible.
   e Set Min Value to 18 and Max Value to 60.

8 From the Task Library pane, under User Prompts, double-click Text Entry, and then give it a descriptive name. For example, E-mail.

9 From the Task Properties pane, configure the Text Entry prompt.
   a Under General, in the Prompt field, type Enter your e-mail address:
   b In the Error Msg field, click <Use Printer Setting>, and then click the ellipsis button.
   c In the Error Msg dialog box, type Please enter a valid e-mail address., and then click OK.
   d In the Help Text field, click the ellipsis button.
   e In the Help Text dialog box, type We will send you an e-mail regarding the status of your loan., and then click OK.
   f Under Restrictions, select Text Visible.
   g Set Min Length to 1, and retain the value in the Max Length field to use the printer settings.
Adding branches

1. From the Task Library pane, under User Prompts, double-click **Multiple Choice**, and then give it a descriptive name. For example, **Loan Type**.

2. From the Task Properties pane, configure the Multiple Choice prompt.
   a. Under General, in the Prompt field, instruct users to select the type of loan that they want to apply for.
   b. In the Choices field, click the ellipsis button.
   c. Click **Add**.
   d. In the Label field, type **Home Loan**. The Value field is automatically populated with this label.
   e. Repeat step c through step d for the Car Loan and the Personal Loan types.
   f. Clear **Allow multiple selections**, and then click **OK**.
   g. Click **Selection Required**.

3. From the Task Library pane, under Actions, double-click **Branch**.

4. In the Branch Source Selection dialog box, select **Selected Option Label** &gt; **OK**.

5. Give the Branch task a descriptive name. For example, **Submit Requirements**.

6. From the Solution Design pane, double-click the Branch task, and then click **OK**.

7. Double-click **Branch (1)**, and then give it a descriptive name. For example, **Home Loan**.

8. Create a task flow for the Home Loan branch.

   **Set up opening message**
   a. From the Task Library pane, under User Prompts, double-click **Message**, and then give it a descriptive name. For example, **Home Loan Requirements**.
   b. From the Task Properties pane, in the Title field, type **Home Loan Requirements**.
   c. In the Message field, click the ellipsis button.
   d. In the Message dialog box, type the documents that the user must scan, and then click **OK**.
   e. From the Justify menu, select **Center**.

   **Set up Scan to Network**
   a. From the Task Library pane, under Actions, double-click **Scan to Network**, and then give it a descriptive name. For example, **Scan to Network**.
   b. From the Task Properties pane, under Connection to Share, select **Prompt at Runtime**.
   c. Provide the URL and credentials necessary to connect to the network folder.
   
   **Note:** If the eSF version of the printer is 3.3.3 and above, and the server uses the SMBv3 protocol, then select **SMBv3 Compatibility Mode**. For more information on checking the eSF version, see “Checking the version of the Embedded Solutions Framework” on page 10.
   d. Under Output, right-click the “File name” field, and then select **Insert Variable**.
   e. In the Variable Selection dialog box, click **Loan Type** &gt; **Selected Option Label** &gt; **OK**.
   f. In the “File name” field, type an underscore ( _ ) after the Selected Option Label variable.
   g. Right-click inside the “File name” field, and then select **Insert Variable**.
h In the Variable Selection dialog box, click **Name** > **Response** > **OK**.

**Note:** The contents of the “File name” field appear as **Loan Type.Selected Option Label_Name.Response**. After you scan a document, the name of the scanned file includes the loan type selected by the user and the name of the applicant.

i Select **Overwrite existing file** and **Append time stamp**.

j In the Timestamp Format field, type the format.

**Note:** For more information, see “Configuring the time stamp format” on page 11.

**Set up confirmation**

a From the Task Library pane, under Confirmations, double-click **E-mail Confirmation**, and then give it a descriptive name. For example, **Confirmation**.

b From the Task Properties pane, under E-mail, in the To field, click the ellipsis button.

c In the Variable Selection dialog box, click **E-mail > Response > OK**.

d In the Cc field, click the ellipsis button, and then type the e-mail addresses where you want to send a copy of the confirmation e-mail.

e In the From field, click `<Use Printer Setting>`, and then specify an e-mail address that you want to appear as the sender in the confirmation e-mail.

f In the Subject field, click `<Use Printer Setting>`, and then type **Home Loan Application Received**.

g In the Message field, click `<Use Printer Setting>`, and then click the ellipsis button.

h In the Message dialog box, type an e-mail message that confirms receipt of the loan application, and then click **OK**.

**Set up closing message**

a From the Task Library pane, under User Prompts, double-click **Message**, and then give it a descriptive name. For example, **Thank you**.

b From the Task Properties pane, under General, in the Message field, click the ellipsis button.

c In the Message dialog box, type **We will contact you as soon as your application has been approved. Thank you for availing our loan program.**, and then click **OK**.

d From the Justify menu, select **Center**.

9 Click the second branch, and then give it a descriptive name. For example, **Car Loan**.

10 Create a task flow similar to the first branch, and then configure the tasks for car loan applications.

11 Click the third branch, and then give it a descriptive name. For example, **Personal Loan**.

12 Create a task flow similar to the other branches, and then configure the tasks for personal loan applications.

13 Assign the branches to the Multiple Choice options.

a Click the main branch.

b From the Task Properties pane, assign a multiple choice option to a branch.

**Note:** If a user selects one of the loan types from the multiple choice prompt, then the selected loan type tasks are launched.

c Under Branch Assignment, in the first box with Home Loan as the Selected Option Label, click the **Unassigned** menu, and then select **Home Loan**.
d In the second box with Car Loan as the Selected Option Label, click the Unassigned menu, and then select Car Loan.
e In the third box with Personal Loan as the Selected Option Label, click the Unassigned menu, and then select Personal Loan.

Validate and deploy the solution

1 Check the solution for errors. Do either of the following:
   • Click Tools > Validate.
   • From the toolbar, click ✓.
2 If there are any errors in the Validation Summary dialog box, then correct the errors and validate again.
3 Check the overall flow of the solution. Do either of the following:
   • Click Tools > Simulate.
   • From the toolbar, click 📝.
4 From the Tools menu, deploy the solution. Do either of the following:
   • Deploy Solution to Printer—Install the solution directly on a printer.
     Notes:
     – This feature is available only in some printer models.
     – To deploy directly to printers, make sure that the printer is on the same network as the Solution Composer Agent. You can use the IP address or host name of the printer.
   • Deploy Solution to File—Create a solution file that can be installed later on a printer.

Sample flow when using the solution

1 From the printer home screen, the user touches the icon for the solution.
2 A welcome message appears. The user then touches Next.
3 The printer prompts the user to type the name.
   The user types the name using the touch-screen keyboard, and then touches Next.
4 The printer prompts the user to enter the age.
   The user enters the age using the numeric keypad, and then touches Next.
5 The printer prompts the user to type the e-mail address.
   The user types the e-mail address using the touch-screen keyboard, and then touches Next.
6 The printer prompts the user to select the loan type that they want to apply for.
   The user makes a selection, and then touches Next.
7 The printer prompts the user to load the specified documents on the scanner glass or into the ADF tray.
8 The user loads the document, and then touches Next.
9 The printer shows a message while the scanned file is saved to the network folder.
10 The printer shows a message while the e-mail confirmation is sent to the specified e-mail address.
11 The printer shows an acknowledgment message.
12 The user touches Next and returns to the home screen.
Troubleshooting

Deployed solutions do not appear on the printer

Try one or more of the following:

**Make sure that Solution Composer Agent is licensed on the printer**

*Note:* For more information, see “Licensing Solution Composer Agent” on page 8 or contact your Lexmark representative.

If solutions were deployed before Solution Composer Agent was licensed on the printer, then restart Solution Composer Agent after licensing to enable the deployed solutions.

1. Obtain the printer IP address. Do either of the following:
   - Locate the IP address on the top or upper-left corner of the printer home screen.
   - View the IP address in the Network Overview section or in the TCP/IP section of the Network/Ports menu.

2. Open a Web browser, and then type the printer IP address.

3. Depending on your printer model, do one of the following:
   - Click Apps > Solution Composer Agent > Stop > Start.
   - Click Settings > Apps > Apps Management > Disable > Enable.
   - Click Settings > Device Solutions > Solutions (eSF).
     - Select the Solution Composer Agent check box, and then click Stop > Start.
   - Click Settings or Configuration, and then click Embedded Solutions.
     - Select the Solution Composer Agent check box, and then click Stop > Start.

**Redeploy the solution**

For more information, see “Step 5: Deploying solutions” on page 16.

**Install the solution from the printer Embedded Web Server**

If the solution cannot be deployed directly to the printer, then try deploying it to a file. Use the Solution Composer Agent application to install the file on the printer Embedded Web Server.

Depending on your printer model, Solution Composer Agent can be deployed from Lexmark Virtual Solution Center. For more information, contact your solution provider.

To access the Solution Composer Agent solution management page from the Embedded Web Server, click Applications > Solution Composer.

**Printer hard disk is missing**

**Make sure that the printer hard disk is installed properly**

For more information, see the printer User’s Guide.
Printer hard disk is full

Make sure that the printer hard disk has sufficient memory
For more information, see the printer User’s Guide.

Cannot send jobs to the remote printer

Make sure that the printer is not currently busy processing another print, copy, scan, or fax job

Make sure that the printer is connected to the network
For more information, see the printer User’s Guide.

OCR or MRC does not work properly

Try one or more of the following:

Make sure that the printer supports OCR and MRC
For more information, see the Readme file.

Make sure that AccuRead OCR is properly installed
For more information, see the AccuRead OCR Solutions Overview. You can also purchase this solution from your solution provider.

Scan to FTP does not work properly

Make sure that FTP is in passive mode

Scan to Fax or fax actions cause the solution to fail

Make sure that the fax settings are configured correctly
For more information, see the printer User’s Guide.
Scan to E-mail or e-mail actions cause the solution to fail

Make sure that the e-mail settings are configured correctly
For more information, see the printer User’s Guide.

Scan to E-mail fails to send an e-mail

Make sure that the recipient e-mail address is valid

1 Obtain the printer IP address. Do either of the following:
   Notes:
   • Locate the IP address on the top or upper-left corner of the printer home screen.
   • View the IP address in the Network Overview or in the TCP/IP section of the Network/Ports menu.
2 Open a Web browser, and then type the printer IP address.
3 Depending on your printer model, do one of the following:
   • Click Settings > E-mail > E-mail Setup.
   • Click Settings or Configuration, and then click E-mail/FTP Settings > E-mail Settings > Setup E-mail Server.
4 In the Reply Address field, type an e-mail address.
5 Click Save or Submit.
Frequently asked questions

Will solutions built using Solution Composer work on my Lexmark printer?
Yes, if you have a multifunction product running a licensed Solution Composer Agent.

*Note:* Multi Send requires a printer hard disk.

Do solutions built using Solution Composer require certification?
No. Solution Composer is designed to produce solutions that can be used immediately.

How do I rename tasks in the Solution Design pane?
Double-click the name of the task below the icon, and then type a new name.

Will later versions of solutions overwrite earlier ones?
Yes. Solution Composer does not check the version of previously deployed solutions.

Why aren't the scan settings that I set in Task Properties working on my printer?
Scan settings vary according to printer model and print job, so not all scan settings are available on all printers in all situations. If the scan settings that you selected for your solution are not supported by a printer, then the default scan settings of the printer are used. For a complete list of available scan settings, see the printer *User’s Guide*.

Do I have to save a project before validating or simulating?
No. You can validate or test projects using Simulate before saving or deploying them.

Do I have to validate or simulate a project before saving or deploying it?
No. You can save or deploy projects without validating or simulating them first. But running one or both of these checks can help make sure that you have a working solution before you load it to a printer device.
Note: Solutions are automatically validated as part of the deployment process.

Why are the Prompts and Actions tasks not completed after I send the scanned files to multiple destinations?
You can add index files and confirmations only after using the Multi Send action with background processing.

Why do my TIFF files contain only black-and-white text?
When TIFF Compression (CCITT) is selected, the content is limited to black-and-white text only. If you want to print other content and use color, then select TIFF Compression (LZW).
Edition notice

February 2020

The following paragraph does not apply to any country where such provisions are inconsistent with local law: LEXMARK INTERNATIONAL, INC., PROVIDES THIS PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied warranties in certain transactions; therefore, this statement may not apply to you.

This publication could include technical inaccuracies or typographical errors. Changes are periodically made to the information herein; these changes will be incorporated in later editions. Improvements or changes in the products or the programs described may be made at any time.

References in this publication to products, programs, or services do not imply that the manufacturer intends to make these available in all countries in which it operates. Any reference to a product, program, or service is not intended to state or imply that only that product, program, or service may be used. Any functionally equivalent product, program, or service that does not infringe any existing intellectual property right may be used instead. Evaluation and verification of operation in conjunction with other products, programs, or services, except those expressly designated by the manufacturer, are the user’s responsibility.

For Lexmark technical support, visit http://support.lexmark.com.

For information on supplies and downloads, visit www.lexmark.com.

© 2017 Lexmark International, Inc.

All rights reserved.

GOVERNMENT END USERS

The Software Program and any related documentation are “Commercial Items,” as that term is defined in 48 C.F.R. 2.101, “Computer Software” and “Commercial Computer Software Documentation,” as such terms are used in 48 C.F.R. 12.212 or 48 C.F.R. 227.7202, as applicable. Consistent with 48 C.F.R. 12.212 or 48 C.F.R. 227.7202-1 through 227.7207-4, as applicable, the Commercial Computer Software and Commercial Software Documentation are licensed to the U.S. Government end users (a) only as Commercial Items and (b) with only those rights as are granted to all other end users pursuant to the terms and conditions herein.

Trademarks

Lexmark, the Lexmark logo, Perceptive Content, and ReadSoft are trademarks or registered trademarks of Lexmark International, Inc. or its subsidiaries in the United States and/or other countries.

Java is a registered trademark of Oracle and/or its affiliates.

Microsoft and Windows are either registered trademarks or trademarks of the Microsoft group of companies in the United States and other countries.

All other trademarks are the property of their respective owners.
Apache License Version 2.0, January 2004

http://www.apache.org/licenses/

TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION

1 Definitions.

"License" shall mean the terms and conditions for use, reproduction, and distribution as defined by Sections 1 through 9 of this document.

"Licensor" shall mean the copyright owner or entity authorized by the copyright owner that is granting the License.

"Legal Entity" shall mean the union of the acting entity and all other entities that control, are controlled by, or are under common control with that entity. For the purposes of this definition, "control" means (i) the power, direct or indirect, to cause the direction or management of such entity, whether by contract or otherwise, or (ii) ownership of fifty percent (50%) or more of the outstanding shares, or (iii) beneficial ownership of such entity.

"You" (or "Your") shall mean an individual or Legal Entity exercising permissions granted by this License.

"Source" form shall mean the preferred form for making modifications, including but not limited to software source code, documentation source, and configuration files.

"Object" form shall mean any form resulting from mechanical transformation or translation of a Source form, including but not limited to compiled object code, generated documentation, and conversions to other media types.

"Work" shall mean the work of authorship, whether in Source or Object form, made available under the License, as indicated by a copyright notice that is included in or attached to the work (an example is provided in the Appendix below).

"Derivative Works" shall mean any work, whether in Source or Object form, that is based on (or derived from) the Work and for which the editorial revisions, annotations, elaborations, or other modifications represent, as a whole, an original work of authorship. For the purposes of this License, Derivative Works shall not include works that remain separable from, or merely link (or bind by name) to the interfaces of, the Work and Derivative Works thereof.

"Contribution" shall mean any work of authorship, including the original version of the Work and any modifications or additions to that Work or Derivative Works thereof, that is intentionally submitted to Licensor for inclusion in the Work by the copyright owner or by an individual or Legal Entity authorized to submit on behalf of the copyright owner. For the purposes of this definition, "submitted" means any form of electronic, verbal, or written communication sent to the Licensor or its representatives, including but not limited to communication on electronic mailing lists, source code control systems, and issue tracking systems that are managed by, or on behalf of, the Licensor for the purpose of discussing and improving the Work, but excluding communication that is conspicuously marked or otherwise designated in writing by the copyright owner as "Not a Contribution."

"Contributor" shall mean Licensor and any individual or Legal Entity on behalf of whom a Contribution has been received by Licensor and subsequently incorporated within the Work.

2 Grant of Copyright License. Subject to the terms and conditions of this License, each Contributor hereby grants to You a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare Derivative Works of, publicly display, publicly perform, sublicense, and distribute the Work and such Derivative Works in Source or Object form.

3 Grant of Patent License. Subject to the terms and conditions of this License, each Contributor hereby grants to You a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable (except as stated in this section) patent license to make, have made, use, offer to sell, sell, import, and otherwise transfer the Work, where such license applies only to those patent claims licensable by such Contributor that are necessarily
infringed by their Contribution(s) alone or by combination of their Contribution(s) with the Work to which such Contribution(s) was submitted. If You institute patent litigation against any entity (including a cross-claim or counterclaim in a lawsuit) alleging that the Work or a Contribution incorporated within the Work constitutes direct or contributory patent infringement, then any patent licenses granted to You under this License for that Work shall terminate as of the date such litigation is filed.

4 Redistribution. You may reproduce and distribute copies of the Work or Derivative Works thereof in any medium, with or without modifications, and in Source or Object form, provided that You meet the following conditions:

a (a) You must give any other recipients of the Work or Derivative Works a copy of this License; and

b (b) You must cause any modified files to carry prominent notices stating that You changed the files; and

c (c) You must retain, in the Source form of any Derivative Works that You distribute, all copyright, patent, trademark, and attribution notices from the Source form of the Work, excluding those notices that do not pertain to any part of the Derivative Works; and

d (d) If the Work includes a "NOTICE" text file as part of its distribution, then any Derivative Works that You distribute must include a readable copy of the attribution notices contained within such NOTICE file, excluding those notices that do not pertain to any part of the Derivative Works, in at least one of the following places: within a NOTICE text file distributed as part of the Derivative Works; within the Source form or documentation, if provided along with the Derivative Works; or, within a display generated by the Derivative Works, if and wherever such third-party notices normally appear. The contents of the NOTICE file are for informational purposes only and do not modify the License. You may add Your own attribution notices within Derivative Works that You distribute, alongside or as an addendum to the NOTICE text from the Work, provided that such additional attribution notices cannot be construed as modifying the License.

You may add Your own copyright statement to Your modifications and may provide additional or different license terms and conditions for use, reproduction, or distribution of Your modifications, or for any such Derivative Works as a whole, provided Your use, reproduction, and distribution of the Work otherwise complies with the conditions stated in this License.

5 Submission of Contributions. Unless You explicitly state otherwise, any Contribution intentionally submitted for inclusion in the Work by You to the Licensor shall be under the terms and conditions of this License, without any additional terms or conditions. Notwithstanding the above, nothing herein shall supersede or modify the terms of any separate license agreement you may have executed with Licensor regarding such Contributions.

6 Trademarks. This License does not grant permission to use the trade names, trademarks, service marks, or product names of the Licensor, except as required for reasonable and customary use in describing the origin of the Work and reproducing the content of the NOTICE file.

7 Disclaimer of Warranty. Unless required by applicable law or agreed to in writing, Licensor provides the Work (and each Contributor provides its Contributions) on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied, including, without limitation, any warranties or conditions of TITLE, NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A PARTICULAR PURPOSE. You are solely responsible for determining the appropriateness of using or redistributing the Work and assume any risks associated with Your exercise of permissions under this License.

8 Limitation of Liability. In no event and under no legal theory, whether in tort (including negligence), contract, or otherwise, unless required by applicable law (such as deliberate and grossly negligent acts) or agreed to in writing, shall any Contributor be liable to You for damages, including any direct, indirect, special, incidental, or consequential damages of any character arising as a result of this License or out of the use or inability to use the Work (including but not limited to damages for loss of goodwill, work stoppage,
9 Accepting Warranty or Additional Liability. While redistributing the Work or Derivative Works thereof, You may choose to offer, and charge a fee for, acceptance of support, warranty, indemnity, or other liability obligations and/or rights consistent with this License. However, in accepting such obligations, You may act only on Your own behalf and on Your sole responsibility, not on behalf of any other Contributor, and only if You agree to indemnify, defend, and hold each Contributor harmless for any liability incurred by, or claims asserted against, such Contributor by reason of your accepting any such warranty or additional liability.

END OF TERMS AND CONDITIONS

APPENDIX: How to apply the Apache License to your work.

To apply the Apache License to your work, attach the following boilerplate notice, with the fields enclosed by brackets "[]" replaced with your own identifying information. (Don't include the brackets!) The text should be enclosed in the appropriate comment syntax for the file format. We also recommend that a file or class name and description of purpose be included on the same "printed page" as the copyright notice for easier identification within third-party archives.

Copyright [yyyy] [name of copyright owner]

Licensed under the Apache License, Version 2.0 (the "License"); you may not use this file except in compliance with the License. You may obtain a copy of the License at

http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.
<table>
<thead>
<tr>
<th>Glossary Item</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Embedded Web Server</td>
<td>The Web interface for printers. You can access it by typing the IP address or DNS host name of a printer into the address field of a Web browser.</td>
</tr>
<tr>
<td>index file</td>
<td>A file that contains data gathered from individual workflow tasks and the overall solution. Generic index files can be created as part of tasks (such as Scan to FTP). They can also be customized as part of the Index File to FTP and Index File to Network tasks.</td>
</tr>
<tr>
<td>simulate</td>
<td>A way to check the basic look, flow, and syntax of a Solution Composer project before deploying it. You can simulate printer solution workflows only.</td>
</tr>
<tr>
<td>solution</td>
<td>Used synonymously with &quot;solution package&quot; to refer to applications built using Solution Composer.</td>
</tr>
<tr>
<td>Solution Composer Agent</td>
<td>A licensed embedded application that lets you install and run solutions on printers after building them using Solution Composer.</td>
</tr>
<tr>
<td>solution package</td>
<td>Used synonymously with &quot;solution&quot; to refer to applications built using Solution Composer.</td>
</tr>
<tr>
<td>solution properties</td>
<td>The overall properties of the solution. They determine such things as the name of the solution and the image that is used for the solution icon on the printer home screen.</td>
</tr>
<tr>
<td>task properties</td>
<td>Properties that determine the behavior of the individual tasks (actions and prompts) in a Solution Composer project</td>
</tr>
<tr>
<td>validate</td>
<td>A way to check a Solution Composer project for errors. Solution packages are validated automatically when deployed to a file or printer.</td>
</tr>
<tr>
<td>variables</td>
<td>A value that represents data drawn from the printer (such as its IP address) or from user input (such as an option that a user selected). Variables are available as an option in most text fields in the Task Properties pane. They are used as a dynamic means of gathering data to report back on system conditions and user choices.</td>
</tr>
<tr>
<td>workflow</td>
<td>The sequence of events created by the group of tasks that make up a Solution Composer project</td>
</tr>
</tbody>
</table>
Index

A
actions (printer)
  Branch 12
  adding
    bar code templates 9
    branches 12
    tasks 12
  arranging tasks 9

B
bar code templates
  adding 9
basic concepts 6
Branch 12
branches
  adding 12
  branching 12
building solutions
  creating projects and adding
    tasks 12
deploying printer solutions
  directly to a printer 16
deploying printer solutions to a
  file 16
saving projects 15
simulating printer solutions 15
validating solutions 14

C
cannot send a scan as an
e-mail 26
cannot send jobs 25
certificate requirement 27
change history 4
configuring
  task properties 9
configuring Timestamp Format 11
creating projects and adding
  tasks 12

D
deleting
  tasks 12
deploying
  printer solutions directly to a
    printer 16
  printer solutions to a file 16
  printer solutions
    deploying directly to a
      printer 16
deploying to a file 16
  samples 18, 19
scenarios, prompt, scan to, and
  save index file 19
scenarios, scan to and prompt 18
simulating 15
  projects
    deploying 27
    saving 15, 27
    simulating 27
    validating 27

R
remote printer
  cannot send jobs 25
renaming tasks in the Solution
  Design pane 27

S
saving projects 15, 27
scan settings in Task Properties
  not working 27
Scan to E-mail causes the
  solution to fail 26
Scan to E-mail fails to send an
  e-mail 26
Scan to Fax causes the solution
  to fail 25
Scan to FTP does not work 25
scenarios
  prompt, scan to, and save index
    file 19
  scan to and prompt 18
simulate
  using to check printer
    solutions 15
simulating projects 27
software requirements 5
Solution Composer Agent
  licensing 8
solution configurations
  exporting 9
Solution Design pane
  renaming tasks 27
solution packages  
  validating 14

solutions  
  adding branches 12
  adding support information 16
  creating projects and adding tasks 12
  deploying to a file 16
  deploying to a printer 16
  saving projects 15
  simulating 15

solutions built using Solution Composer  
  certificate requirement 27
  support on Lexmark printers 27

solutions do not appear on the printer 24

support information  
  adding to a solution 16

system requirements 5

T

Task Library 6

  task properties  
    configuring 9

  tasks  
    adding 12
    arranging 9
    deleting 12
    renaming 27
    understanding 6

templates  
  bar code management 9
  TIFF Compression 27
  Timestamp Format  
    configuring 11

troubleshooting  
  cannot send jobs to remote printer 25
  e-mail actions cause the solution to fail 26
  e-mail is not sent 26
  e-mail solution failure 26
  fax actions cause the solution to fail 25
  fax solution failure 25
  OCR or MRC does not work 25
  printer hard disk is full 25
  printer hard disk is missing 24
  Scan to E-mail causes the solution to fail 26
  Scan to E-mail fails to send an e-mail 26
  Scan to Fax causes the solution to fail 25
  Scan to FTP does not work 25
  solutions do not appear on the printer 24

U

  using variables 9

V

  validating projects 27
  validating solutions 14

variables  
  using 9