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Overview

Lexmark™ Fleet Manager is a suite of tools that helps organizations save costs and improve productivity by
making printer usage and maintenance easy to manage.

The central server component of Lexmark Fleet Manager is Lexmark Fleet Tracker, which provides the primary
user interface for the solution.
Lexmark Fleet Manager supports the following data collectors:

® | exmark Remote Asset Manager

®* Embedded Lexmark Remote Asset Manager

® | ocal Printer Management Agent

®* Embedded Services Monitor
These data collectors track printer and user data, and then roll them up to the primary Fleet Tracker or Managed
Service Provider. For more information, see the documentation for each data collector.
To manage printing environments effectively, Lexmark Fleet Manager can do the following:

® Monitor printers.

® Calculate printing costs from a corporate, group, or cost-center perspective, and account for other printing
cost factors, such as downtime, maintenance, storage space, and supplies.

® Provide graphical reports of printer usage, including the number of jobs and pages printed, the number of
printers used, energy consumption, and supplies costs.

®* Manage printer servicing, including printer maintenance schedules, automated e-mail alerts for printer
supply levels, and service tickets.

This document provides instructions on how to configure, use, and troubleshoot Fleet Tracker.
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Getting started

System requirements

Hardware requirements

Processor RAM Hard disk drive

Intel Core i7 processor or | At least 6GB At least 50GB
equivalent (such as the Intel
Xeon processor E5 product
family, which uses the
Hyper-Threading
Technology).

Note: We recommend backing up the database regularly and implementing a data retention policy of at least
every 12 months.

Supported Microsoft Windows operating systems
* Windows Server 2019
® Windows Server 2016

Windows Server 2012 R2

Windows Server 2012

Windows Server 2008 R2

Supported databases
® Oracle™ Database 19¢
® Oracle Database 18c
® Oracle Database 12c Enterprise Edition
® Oracle Database 12c Standard Edition
® Oracle Database 11g Express Edition
® Oracle Database 11g Standard Edition One
* Oracle Database 11g Standard Edition
® Oracle Database 11g Enterprise Edition
® PostgreSQL version 11.3

Supported web browsers
® Microsoft Edge
® Google Chrome™ version 34.x or later
* Mozilla Firefox version 28.x or later
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Setting up the database

Before you begin, make sure that:
® The Oracle database is installed. For more information, see the documentation for Oracle.
® You have the createORA.sql file provided by your Lexmark representative.

Notes:

® A fresh installation of Fleet Tracker version 4.1 generates a self-signed certificate with a validity of 10
years. A fresh installation also lets the system run on the SSL port using the self-signed certificate. For
more information on securing server communication, see “Securing server communication” on
page 37.

® The PostgreSQL version 11.3 database is installed automatically when installing Fleet Tracker version 4.

® When using an older version of the PostgreSQL database, updating Fleet Tracker to version 4 also
updates the database to version 11.3.

® When you install the Oracle database, make sure that the Global Database Name and the System
Identifier (SID) are the same.

* Note the Global Database Name, URL or IP address, user name, and password. These data are required
during the Fleet Tracker installation.

® Make sure that the Oracle administrator account and password are set up during the Oracle installation.
Before you install Fleet Tracker, create two database schemas by doing the following:
1 Save the createORA.sql file to a temporary directory.
2 Run the command prompt as an administrator.
3 At the command prompt, navigate to the temporary directory, and then type the following:
sqlplus oracleadmin/oraclepassword @createORA.sql ID PW

Where IDand Pware the database user ID and password. The Fleet Tracker server uses these credentials
to access the database. Do not use the same administrator credentials for the Fleet Tracker server or the
Oracle server.

Notes:
® The Oracle script creates two Oracle users needed for the Fleet Tracker installation. After running the
script, make sure to restart the Oracle server.

® The password expiration policy of the database affects the frequency of revalidating your database
account.
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Configuring remote database connection

Set up a connection to the Fleet Tracker database from a computer that does not have the solution installed.
This setup is required when using a tool to create reports, such as the PENTAHO® software Pentaho Report
Designer.

1 During the Oracle database installation, depending on your configuration, set the Global Database Name
and SID to oxcl or xe.

2 During the Fleet Tracker installation, depending on your configuration, from the Oracle database connection
settings, in the Database URL field, type either of the following:

® TP:1521/0xcl
® IpP:1521/xe

Where IPis the IP address of the database server and 1521 is the listening port of the Oracle database.

Accessing the Fleet Tracker web portal

Note: Make sure that the firewall settings are configured to allow access to Fleet Tracker.
1 Open a web browser, and then type the Fleet Tracker IP address.

Note: If you are not using port 80, then add a colon and the port number to the URL. For example,
123.123.123.123:90

2 Enter your credentials. The default user name is admin and the default password is Administratorl.
The default password must be changed after the first login. For more information, see “How do | change
my password?” on page 44.

Note: We recommend adding at least two super administrators as backup. For more information on user
roles and adding new users, see “Configuring user access” on page 41.

Upgrading Fleet Tracker

Note: The upgrade may take up to four hours, depending on the performance of the server and the number
of printers monitored in Lexmark Fleet Tracker.
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1 From the Fleet Tracker web portal, at the lower-left corner of the page, click About.

2 Click Apply Updates.

Note: If this button does not appear, then you have the latest version of Lexmark Fleet Tracker and do not

need to upgrade.

3 Click Close.

Activating the Fleet Tracker license

When applying a license, specify which printers to monitor by changing its state to managed or unmanaged.
The printers in these states are considered licensed printers. If you want to monitor more printers that exceed
the number allotted by the license, then purchase more Fleet Tracker licenses.
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Notes:

® Each license file is associated with a specific MAC address and works only for the server with that
address. If your server has multiple MAC addresses, then associate license files with a MAC address that
does not change.

* To install Fleet Tracker on a different server, then acquire new license files.

® For unlicensed printers, the collected data are not stored in the database. For unlicensed printers that
were previously licensed, the data from the period when they were licensed can be accessed in the
historical data views.

To obtain a license file, provide your Lexmark representative with the MAC address of your Fleet Tracker server.
Your representative uses the MAC address to generate a license file for your Fleet Tracker.

Lexmark  Fleet Tracker ¢' (7]

Dashboard Manage ~ Reports ~

System Configuration

I £ Server
CABEsilaea Fleet Tracker License Fleet Tracker License
@ Vendors Server Host ID(s): f48e3891dcc5 Server Configuration
# Email Notification Expiration Date: 02/07/20 2:30:00 AM Logging
Total Allotted Devices: Unlimited S
8 Rollup by E-mail Number of Devices Remaining: Unlimited Back to top

= System Integration i
Apply New License

s
& Users 3 :
License File

{ Choose File | No file selected

Server Configuration
Bind Address

e A0V 1LO AN | rmsn bbb £mv rall e denrcas)

1 From the Fleet Tracker web portal, do either of the following:
® Click the link in the license information message at the top of the web portal.

® Click a‘ > Server.

2 From the Apply New License section, browse to the license file.

3 Click Apply > Close.

Notes:
® As long as allotted printers are available for your license, newly discovered printers are set to a
Managed state automatically.

® Unlicensed printers remain in Discovered state. You can change the state of printers from the Devices
tab. For more information, see “Understanding printer states” on page 19.
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Checking the Fleet Tracker version and license

1 From the Fleet Tracker web portal, at the lower-left corner of the page, click About.
2 From the Versions and Upgrades section, check the version of Fleet Tracker.

Notes:

* |f the Apply Updates button appears, then you do not have the latest version of Fleet Tracker.

* A fresh installation of Fleet Tracker version 4.1 generates a self-signhed certificate with a validity of 10
years. A fresh installation also lets the system run on the SSL port using the self-signed certificate.
For more information on securing server communication, see “Securing server communication” on

page 37.
3 From the Fleet Tracker License section, check the details of your Fleet Tracker license.

Note: You can also see the license details in the Server page of System Configuration.

4 Click Close.

Managing profile information

b Lexmark Fleet Tracker ﬁ (2]

Dashboard Manage ~ Reports ~

My Account

General Information General Information

Contact Information

Back to top

Display Name
[ Admin ‘

Password

following: uppercase letters, lowercase letters, numeric digits, and/or special characters (e.g.

Confirm Password

1 From the Fleet Tracker web portal, click your user name on the upper-right corner of the page, and then
click My Account.

2 From the General Information section, enter the appropriate information.
Notes:

®* The User ID and Role settings cannot be edited.

® Only the logged in user can change their password. After changing the password, the user is
automatically logged out of the system. On the next login, use the new password.
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® |f a user forgets their password, then a super administrator can reset the password of any user in the

system. The password is reset to a random default, and then shown after the password reset.
3 From the Contact Information section, enter the appropriate information.

4 Click Save Changes.

Understanding the search feature

Starting Fleet Tracker version 4, a search feature is added to the Devices, Tickets, and Data Collectors tab. You

can search for details such as the following:
® |P address

® Serial number

* MAC address

® DNS hosts name

® Assettag

® Contact name

* Contact information

Notes:

® When searching for printers, you can also type a substring of filters or any value of the filters.

®* When exporting data while search filters are enabled, only data that are currently shown in the search
results are exported in CSV format.

® Customize the data shown using the left pane filters. The filters are populated based on the search
results.

® The printer supplies information are located in the Device Details tab of a printer.

Understanding the advanced search
Use the Advanced Search feature to find specific data. This feature is available only in the Devices tab.
1 From the Fleet Tracker web portal, click Manage > Fleet > Devices.
2 Near the search field at the upper-right corner of the page, click Advanced Search.
3 Configure the filters.
4 If necessary, click Add Rule to add another filter.
5 Click Search.

Note: To remove all advanced search filters, near the search field at the upper-right corner of the page, click

Clear all.
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Managing views

Comparison of the Views feature between Fleet Tracker versions 4 and
312

Version 4 or later Version 3.12 or earlier
® The default view shows the preconfigured columns. * The following preset views show the preconfigured
* You can create multiple views. columns:
® When creating a view, you can add custom columns. — Inventory
You can also select all the columns of each category. — Status
® You can set the created view as the default view. — Supplies
— Usage

For example, selecting the Status view shows only
the applicable columns.

® You cannot create a view. You can only add columns
to an existing view.

Note: When upgrading to Fleet Tracker version 4, only the system default view with predefined columns is
available. However, you can create a custom view, and then set it as your default view. For more information,
see “Creating a view” on page 12.

Lexmark  Fleet Tracker & 0

Dashboard Manage ~ Reports ~

Fleet

All Groups Change

Devices Print Users Print Queues Tickets Policies Data Collectors
» Manufacturer . -
& Device ~ | [= Export c Search IP address, serial | Q
> Model Advanced Search  Clear Search
» State 2726 total items
Name Graphics Color Highlight Color Business Color Total Page Count Mono Page Count Color Page Count Print
> Device Status © 45145PLM2PCCO 63523 63523 0 4¢
» Printer Status | ©45145PLM2PC63 54083 54083 0 51
© 45145PLM2PCAL 98154 98154 0 50
eoccorcbe © 45145PLM2PCEX 136312 136312 0 3
© 45145PLM2VTW4 13702 13702 0 67
© 45145PLM2PC81 23598 23598 0 21
© 45145PLM2V4R8 111592 11592 0 1
© 45145PLM2V4R8 M592 M592 0 1
© 45145PLM2V4R8 mMs92 M592 0 1
] © 45145PLM2PCAM 140046 140046 0 2t

Creating a view
1 From the Fleet Tracker web portal, click Manage > Fleet > Devices.

2 If necessary, select a client or group. For more information, see “Selecting a client or group” on page 16.

3 Click Views > Create View.
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4 From the General section, enter the appropriate information.
5 From the View Columns section, configure the settings.

Notes:

® To add or remove a column, click the right or left arrows, respectively.
® To organize the order of columns, click the up or down arrows.
® You can also add an entire category such as Counters, Dates, or Identification.

6 Click Create View.

Setting a default view
1 From the Fleet Tracker web portal, click Manage > Fleet > Devices.

2 If necessary, select a client or group. For more information, see “Selecting a client or group” on page 16.

3 Click Views > Manage Views.

4 Sclect a view, and then click Set As Default.

Editing a view
From the Fleet Tracker web portal, click Manage > Fleet > Devices.

If necessary, select a client or group. For more information, see “Selecting a client or group” on page 16.

Click Views > Manage Views.
Select a view, and then click Edit.

From the General section, enter the appropriate information.

O U1 A W N A

From the View Columns section, configure the settings.

Notes:

® To add or remove a column, click the right or left arrows, respectively.
® To organize the order of columns, click the up or down arrows.
® You can also add an entire category such as Counters, Dates, or Identification.

7 Click Save Changes.

Deleting a view
1 From the Fleet Tracker web portal, click Manage > Fleet > Devices.

2 If necessary, select a client or group. For more information, see “Selecting a client or group” on page 16.

3 Click Views > Manage Views.
4 Seclect a view, and then click Delete.

5 Click Delete View.

Note: Deleting a default view reverts the view to Default System View. The Default System View cannot be
deleted.
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Managing the dashboard

Understanding the dashboard

1 From the Fleet Tracker web portal, click Dashboard.

Note: The dashboard is the default landing page view.

2 Review any of the following:

* Fleet Details—A chart that summarizes the following fleet details:

Active Data Collectors—The number of data collectors that are active in the fleet and linked to the
LFT server

Active Devices—The number of printers that are active in the fleet

Color Devices—The number of printers in the fleet that can print in color

License Remaining—The number of licenses that clients can use

Managed Devices—The number of printers that have users managing their status
Total Data Collectors—The number of data collectors that are linked to the LFT server
Total Devices—The number of printers connected to the LFT server

® Page Volume Trends—A chart that summarizes the number of pages printed in the last 12 months

* Number of devices per manufacturer—A chart that summarizes the number of printers connected to
the LFT server and grouped by manufacturer

® Device Status—A chart that summarizes the status of the printers that are connected to the LFT server

® Ticket—A chart that summarizes the tickets in the system

Note: For more information on configuring the Ticket widget, see “Configuring the dashboard” on
page 38.

* Toners ending in next yy days—A chart that estimates the toners that may be empty in the next specified
days based on your usage data

Note: For more information on configuring the Supply widget, see “Configuring the dashboard” on
page 38.

Hover your mouse over the following widgets to view their details:

Page Volume Trends

Number of devices per manufacturer

Device Status

Ticket

Toners ending in next yy days

The following charts direct to another window when clicked:

Number of devices per manufacturer

Device Status

Ticket

Toners ending in next yy days
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Checking the system health

1 From the Fleet Tracker web portal, click Dashboard.

2 From the top left corner of the page, click the status for System Health Status.

3 Click any of the following to view its details:
* JVM Memory

Recommendation X

JVM Memory
« The required JVM memory is 2 GB. Increase the JVM memory by 1 GB if the JVM
memory usage crosses 80 percent of the recommended limit
« Contact LFM Help if the JVM memory continues to be in the red zone.

Close

® JVM Thread

Recommendation X

JVM Thread
+ The recommended thread count should be within 100.
« Contact LFM Help if thread count crosses 300 and continues to be high

Close

® Device Count

Recommendation X

Device Count
» Recommended Oracle XE supported device count: 5000
+ Recommended PostgreSQL supported device count: 2500
+ Upgrade to Oracle SE DB if the supported device count exceeds the maximum

supported devices as per recommendation.
Close

® Warehouse Usage

Recommendation X

Warehouse Usage
= Prune the Warehouse DB if the warehouse usage crosses 80 percent of the
recommended limit
« Upgrade to Oracle SE DB if the warehouse usage crosses 80 percent of the

recommended limit
Close

Note: In Oracle 12¢, Device Count and Warehouse Usage are not available.

4 Click Close.

Note: Dashboard shows data based on the information available at the time the user logs in. To show the

latest data, refresh the web browser.
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Managing the fleet

Managing clients and groups

Create groups and clients to simplify the monitoring of printer usage and the generation of reports.

Selecting a client or group

Lexmark  Fleet Tracker

Dashboard

Manage ~

o)

Reports ~

Dashboard

All Groups Change

System Health Status @ Good

Page Volume Trends: 12 Months

Number of devices per manufacturer

Fleet Details
Active Data Collectors: i Type Type
a a8
Active Devices: 104 10.000.000
1,500
Color Devices: 133 © 8000000 ]
E
) . L E
License Remaining: Unlimited 3 000000 060
Managed Devices: 1956 3
£ 4000000
Total Data Collectors: 1796 560
Total Devices: 2726 2000,000

mmmmmmmmmmmm

“““““““

Months

1 From the Fleet Tracker web portal, at the upper-left corner of the page, following All Groups, click

Change.
2 Select a client or group.

3 Click Select.

Creating a group

Groups can be used to organize printers, clients, and other groups.

1 From the Fleet Tracker web portal, click Manage > Groups and Clients.

2 Do either of the following:

® To create a group, click Create Group.
* To add a group to an existing group or client, select a group, and then click 4= > Group > Continue.

Note: You can edit or delete groups.

3 Enter the appropriate information.

4 Click Create Group.
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Creating a client

Create printer groups and clients to simplify the monitoring of printer usage and the generation of reports.
Clients are used to organize printers and groups for a single customer, and you cannot nest a client under a

client.

1 From the Fleet Tracker web portal, click Manage > Groups and Clients.

2 Do either of the following:
® To create a client, click Create Client.
* To add a client to an existing group, select a group, and then click 4= > Client > Continue.

Note: You can edit or delete clients.
3 Enter the appropriate information.

4 Click Create Client.

Managing printers

Note: Customize the data shown using the left pane filters. The filters are populated based on the search
results.

Managing printers in groups
1 From the Fleet Tracker web portal, click Manage > Fleet > Devices.

2 If necessary, select a client or group. For more information, see “Selecting a client or group” on page 16.

3 Select one or more printers, and then click Device.

4 Do either of the following:
® Click Move, and then select the client or group to where you want to move the printers.

Note: Moving a printer to another client or group removes it from the client or group that it is in,
depending on the level of the destination.

® Click Copy, and then select the client or group to where you want to copy the printers.
Some printers may be moved from one location to another. A printer can be associated with its new group
automatically during a rollup. The following scenarios show how Fleet Tracker manages the printer when it is
moved to another location:
® Scenario 1: A printer is associated with one group.
Ifthe printeris rolled up from a different data collector, then the printeris moved to a new group automatically.
Only the most recent data are added to the new group, and the historical data are removed from the old
group.
® Scenario 2: A printer is associated with multiple groups.
If the printer is associated with a group that contains multiple subgroups, then all instances of the printer

are removed from the old group and subgroups. Only one instance of the printer appears in the new group
that corresponds to the data collector from where the most recent data are rolled up.
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® Scenario 3: A printer is rolled up from Local Printer Management Agent.

If the printer status is offline in Fleet Tracker, then the printer is moved to the new group automatically. The
connection type of the printer changes from network to USB, and all other printer data for Local Printer
Management Agent are updated accordingly.

® Scenario 4: A printer is moved to a different group manually after being moved automatically.

The next rollup from the same data collector does not override the manual move. If the next rollup is from
a different data collector, then the printer is moved to a new group automatically.

® Scenario 5: A printer is rolled up from a data collector without a site location.

If a data collector does not have a site location, then the printer is rolled up to a client instead of a group.
A user may create a group under the client, and then copy a printer from the client to the group. If the data
collector in the next rollup has a site location, then the printer appears under a new group that represents
the site location. The printer is removed from the client, but the copy of the printer from the user-created
group under the client is retained.

Removing printers from groups
1 From the Fleet Tracker web portal, click Manage > Fleet > Devices.

2 Select a client or group. For more information, see “Selecting a client or group” on page 16.

3 Select one or more printers, and then click Device.

4 Click Remove from Group > Yes.

Managing an individual printer
1 From the Fleet Tracker web portal, click Manage > Fleet > Devices.

2 If necessary, select a client or group. For more information, see “Selecting a client or group” on page 16.

3 Click a printer name, and then do one or more of the following:
Note: You can also export the list of printers.

* From the Device Details tab, view information about the printer, including its location, status, page count,
and supplies.

® From the Ticket tab, review, create, delete, or export tickets associated with the printer.
® From the Policy tab, create, edit, or delete the printer policy.

® From the Historical View tab, export or view archived information about the printer.

® From the Create Report tab, generate, view, send as e-mail, or export reports.

Note: Generating reports is not supported at the printer level.
®* From the Log tab, view the log for the printer.

Note: Changes made to settings at the printer level override settings at the group level.

Adding a printer manually
1 From the Fleet Tracker web portal, click Manage > Fleet > Device > Add.

2 Enter the appropriate information.
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3 If necessary, add another printer.
4 Click Ok.

Note: Printers that are added manually are set to storage state. Data is not collected from printers that are
added manually unless a data collector discovers these printers.

Understanding printer states

You can set the printers to one of the following states:

* Discovered—These printers have been discovered, but are not being actively monitored. The collected
data are not stored in the database. Discovered printers do not count against the number of allotted printers
in your license. If you exceed the number of allotted printers in your license, then newly discovered printers
are set to this state.

® Managed—These printers are monitored in the system, and the collected data are stored in the database.
Managed printers count against the number of allotted printers in your license. When printers are
discovered, they are set to this state automatically while your allotted printers last.

® Retired—These printers are no longer used, and no data is collected from them. You can set the printers to
this state to keep them in the system for historical data. Retired printers do not count against the number
of allotted printers in your license.

® Storage—These printers are currently not used, and no data is collected from them. You can set the printers
to this state to keep them in the system for future monitoring. Storage printers do not count against the
number of allotted printers in your license.

* Unmanaged—These printers are similar to managed printers, but can be classified according to whether
you are charging for their use currently or in the future. Unmanaged printers count against the number of
allotted printers in your license.

Note: The values in some columns are no longer shown. When sorting or filtering printers by columns, the
printers are listed in the same manner as when the values of the columns were still shown.

Changing printer states

1 From the Fleet Tracker web portal, click Manage > Fleet > Devices.
2 Select one or more printers.

3 Click Device, and then select a printer state.

Note: For more information, see “Understanding printer states” on page 19.

Understanding device statuses

In Fleet Tracker, each device is associated with a device or printer status.

Device status

The device status refers to the current operational state of the device.
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Note: When using the Embedded Lexmark Remote Asset Manager, we recommend discovering and
collecting only up to 100 devices. Rolling up more than 100 devices shows a message with the data collector
status.

®* Running—The device is operating normally.

* Inactive—The device is not active.

* Warning—An error has been detected but the device is still usable.
®* Down—The device is not usable.

* Unknown—Fleet Tracker cannot determine the device status.

* Testing—The device is in a testing state and cannot be used.

Printer status
The printer status refers to the current state of the printer portion of the device; multifunction products have
features beyond just printing jobs.

® |dle—The printer is idle.

® Warmup—The printer is in the process of warming up.

® Printing—The printer is in the process of printing a document.

® Other—The printer state could be in one of several miscellaneous states.

®* Unknown—Fleet Tracker cannot determine the printer status.

Managing custom columns

Custom Columns

+ Create

Name Include in E-mail
SDA

cust T_NM_jata

Cancel

1 From the Fleet Tracker web portal, click Manage > Fleet > Devices.

2 If necessary, select a client or group. For more information, see “Selecting a client or group” on page 16.

3 Click Views > Manage Views > Custom Columns.
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4 Click Create.

Note: You can also delete custom columns.
5 To change the column name, click the default name, and then enter a new name.
6 To receive e-mails on the custom columns, select Include in E-mail.

7 Click Submit.

Adding custom columns in Views

Lexmark  Fleet Tracker & 0
Dashboard Manage ~ Reports ~

Devices * Views

Manage Views

+ Create W Delete % Set As Default

View Description
IP_Address
Important information %

LFT4_View

Default System View Non-modifiable System View

From the Fleet Tracker web portal, click Manage > Fleet > Devices.

If necessary, select a client or group. For more information, see “Selecting a client or group” on page 16.
Click Views > Manage Views.
Select a view, and then click Edit.

From the Possible columns section, click CUSTOM, click the custom column, and then click >.
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Click Save Changes.

From the Devices tab, the custom column appears in the selected view.
7 If necessary, scroll to the custom column, and then enter the appropriate information in each cell.

Note: The entered information is saved automatically.

Managing print users

1 From the Fleet Tracker web portal, click Manage > Fleet > Print Users.

2 If necessary, select a client or group. For more information, see “Selecting a client or group” on page 16.

3 Do any of the following:
Note: You can also export the list of print users.

® To add a name or e-mail address for the user, click the cell in the Name or E-mail column, and then add
the appropriate information.

® To view or export the print queue of a user, click the value in the Total Print Queues column.
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® To view or export the print jobs of a user, click the value in the Total Jobs column.

Viewing print queues
1 From the Fleet Tracker web portal, click Manage > Fleet > Print Queues.

Note: You can also export the list of print queues.

2 To view the details of a print queue, click a computer name, and then click the print driver name.

Managing data collectors

Note: Customize the data shown using the left pane filters. The filters are populated based on the search
results.

Comparison of the Data Collectors tab between Fleet Tracker versions 4
and 312

Version 4 or later Version 312 or earlier

® Toviewthe clientor group associated with a data collector,| ® A client or group must be selected before the
navigate to the Data Collector tab. details for the data collector can be viewed.

® You can filter the data collector list by its status or type. ® You can filter all data collector columns.

Understanding data collector statuses
Note: The Nearing end of life and End of life statuses are applicable to all data collectors.

* Provisioned—The data collector is ready to enroll to the server.

* Running—The data collector is enrolled and ready to send data to the Fleet Tracker server.

® Stopped—The data collector service is stopped from the machine where it is installed.

® Unenrolled—The data collector is no longer enrolled from the Fleet Tracker server and no data is sent to
the server.

* Uninstalled—The data collector application is uninstalled.

* Pending Deletion—The data collector is removed from the Fleet Tracker server. This status applies to only
data collectors that were previously in Running state. If the rollup connection is set to HTTP, then the data

collector is deleted automatically in the next job schedule. If the rollup connection is set to e-mail, then the
user must delete the database collector manually by clicking Force Delete.

* Unresponsive—The data collector cannot communicate with the Fleet Tracker server for more than 24
hours. This status appears only if the rollup connection is set to HTTP or HTTPS.

* Nearing end of life—The data collector is nearing end of life. The current Lexmark Fleet Tracker version is
the last version that is supporting this data collector type. All rollups from this data collector are rejected in
the next Fleet Tracker version.

* End of life—The data collector has reached its end of life and is not supported by the current Lexmark Fleet
Tracker version. All rollups from this data collector are rejected. For more information, contact a Lexmark
representative.
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Viewing rights for the Asset Manager Information window

Remote Asset Task Details Remote Management Enrollment Code
Manager

Environment
Provisioned X X v X
Running v v X v
Stopped v v X X
Unenrolled v X X v
Uninstalled v X X v
Pending v v X X
Deletion
Unresponsive v v X X

Enabled tabs for the Edit Data Collector Settings window

Status General Information Remote Asset Manager
Provisioned v v
Running v v
Stopped v X
Unenrolled v X
Uninstalled v X
Pending Deletion X X
Unresponsive v X

Remote asset managers

Fleet Tracker supports the following remote asset manager data collectors:

* Lexmark Remote Asset Manager—An application that lets you discover printers, collect printer data, and
access advanced data collector features.

* Embedded Lexmark Remote Asset Manager—A printer application that provides better communication of
customized data to Fleet Tracker.

Note: When you use the Embedded Lexmark Remote Asset Manager, we recommend discovering and
collecting only up to 100 printers. Rolling up more than 100 printers shows a message with the data collector
status.

Provisioning the data collector
Note: When installing the Embedded Lexmark Remote Asset Manager on a group or client, make sure that:

® Other data collectors are stopped when installing in a group that uses another data collector.

® Printers rolled up by other data collectors are rolled up again using the Embedded Lexmark Remote Asset
Manager.
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From the Fleet Tracker web portal, click Manage > Fleet > Data Collectors.

Select a client or group. For more information, see “Selecting a client or group” on page 16.

Click Data Collector > Add.

From the General Information section, enter the appropriate information.

g »h W N o

If necessary, from the Settings section, select Enable Privacy.

Note: This setting prevents the data collector from sending sensitive information, such as IP address,
MAC address, contact name, and contact location.

6 Click Submit.

”

7 Note the enrollment code, or send it as an e-mail. For more information, see “E-mailing the enroliment code
on page 24.
Note: Use the enroliment code to configure the rollup settings on remote asset manager data collectors.

For more information, see the Lexmark Remote Asset Manager Administrator’s Guide or the Embedded
Lexmark Remote Asset Manager Administrator's Guide.

E-mailing the enroliment code
1 From the Fleet Tracker web portal, click Manage > Fleet > Data Collectors.

2 Locate either of the following data collectors:
® | exmark Remote Asset Manager
® Embedded Lexmark Remote Asset Manager

3 In the Status column, click Provisioned.
4 Click E-mail Enroliment Code.

5 In the Email List dialog box, do any of the following:
® In the Find User field, type the name of a user that has an e-mail address registered in Fleet Tracker.

® |n the Other recipients field, type one or more e-mail addresses. Use a semicolon to separate multiple
e-mail addresses.

® Select user names that have an e-mail address registered in Fleet Tracker.

6 Click Send.

Reprovisioning the data collector

1 From the Fleet Tracker web portal, click Manage > Fleet > Data Collectors.
2 Locate the data collector, and then in the Status column, click Uninstalled or Unenrolled.
3 Check the last enroliment details.
4

Note the enroliment code or send it as e-mail. For more information, see “E-mailing the enrollment code”
on page 24.
Note: Use the enroliment code to configure the rollup settings on remote asset manager data collectors.

For more information, see the Lexmark Remote Asset Manager Administrator’s Guide or the Embedded
Lexmark Remote Asset Manager Administrator's Guide.
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Editing the remote asset manager data collector settings

To enable this feature, make sure that:
* Only one remote asset manager data collector is selected at a time. You can select either of the following:
— Lexmark Remote Asset Manager
— Embedded Lexmark Remote Asset Manager
® The data collector is connected using HTTP or HTTPS.

Note: When using Lexmark Remote Asset Manager, if the rollup method is manual or e-mail, then only
the General Information tab is available.

The edit option is unavailable when multiple data collectors of different types from the same group or from
different groups are selected. You can edit multiple data collectors of the same type from different groups or
clients, but some fields may not be available.

1 From the Fleet Tracker web portal, click Manage > Fleet > Data Collectors.

If necessary, select a client or group. For more information, see “Selecting a client or group” on page 16.

Select a data collector, and then click Data Collector > Edit.

From the General Information section, enter the appropriate information.

g A W N

From the Settings section, do any of the following:
Note: Only super administrators can edit all the settings. Administrators can edit only the Enable Auto
Device Support Update and the LPMA Aggregator settings.

Update the printer support automatically
Select Enable Auto Device Support Update.

Prevent the data collector from sending sensitive information
Select Hide Confidential Information.
Note: Sensitive information includes printer DNS host name, IP address, MAC address, contact name,
and contact location.

Aggregate Lexmark Print Management Agent

Create a single point of communication to the Fleet Tracker server for all Local Printer Management Agent
using the Lexmark Remote Asset Manager.

Note: This feature is available only in Lexmark Remote Asset Manager.
Select Enable LPMA Aggregation.
Notes:

® Make sure that the Lexmark Remote Asset Manager server address is set in the Local Printer
Management Agent configuration file. For more information, see the Local Printer Management
Agent Administrator’s Guide.

® | exmark Remote Asset Manager starts collecting rolled up data and sending them to the Fleet
Tracker server every hour automatically. For more information, see the Lexmark Remote Asset
Manager Administrator’s Guide.
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Configure the log levels
In the Log Level menu, set the log level.

Note: The log file is exported at \\Lexmark\Fleet Tracker\diagnostics.
Configure the job poll interval
From the Job poll interval section, set the interval in minutes.
Note: The job poll interval must range from 5 to 60 minutes. The default value is 15 minutes.

6 Click Submit.

Accessing the asset manager information

To enable this feature, make sure that:
® The data collector type is either of the following remote asset manager data collectors:
— Lexmark Remote Asset Manager
— Embedded Lexmark Remote Asset Manager
® Only one remote asset manager data collector is selected at a time.
® The data collector is in a running, unresponsive, stopped, or pending deletion state.

From the Fleet Tracker web portal, click Manage > Fleet > Data Collectors.

If necessary, select a client or group. For more information, see “Selecting a client or group” on page 16.

Locate a data collector, and then click the status of the data collector.

A W N A

In the Asset Manager Information window, do any of the following:

Note: Only super administrators can access all tabs. Administrators can access only the Remote Asset
Manager Environment and the Task Details tabs.
®* From the Remote Asset Manager Environment tab, view the data collector information.

® From the Task Details tab, view the list of tasks and their details created in the last 30 days. Information
is shown in the Schedule column only when the task status is Undelivered. To delete the password, click
Clear Password.

®* From the Remote Management tab, do any of the following:
— To run a full discovery for the fleet, click Execute Discovery.
— To run a full collection for the fleet, click Execute Full Collection.
— To collect diagnostic data, click Collect Diagnostic Data.
— To download the diagnostic data after collection, click Download.

5 Click Close.

Local Printer Management Agent

Configuring the Local Printer Management Agent settings
1 From the Fleet Tracker web portal, click Manage > Fleet > Data Collectors.

2 If necessary, select a client or group. For more information, see “Selecting a client or group” on page 16.

3 Select a Local Printer Management data collector, and then click Data Collector > Edit.
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4 From the Settings section, configure the following:

Job Report—Sends job reports to the Fleet Tracker server on each specified day of the week, within the
specified start time and end time. The repeat interval can be either in minutes or in hours, and the default
setting is two hours. Select one or more of the following information that you want to include in the job
reports:

— Track User Printing—When enabled, the user information is included.
— Include Document Names—Includes the names of the printed documents.

— Track Local Printer Queues—Tracks the printing activity of local (USB, DOT4, parallel, or serial port)
printers.

— Track Networked Printer Queues—Tracks the printing activity of network printers.

Inventory Report—Sends inventory reports to the Fleet Tracker server on each specified day of the
week, within the specified start time and end time. The repeat interval must be at least one hour, and
the default setting is three hours.

Blackout Schedule—Disables the communication between Local Printer Management Agent and the
LFM server. This function is triggered on each specified day of the week, within the specified start time
and end time. This setting is disabled by default.

Remote Configuration—Retrieves the Local Printer Management Agent configuration from the Fleet
Tracker server on each specified day of the week. The repeat interval must be at least one minute, and
the default setting is 12 hours.

Software Update—Checks software updates for Local Printer Management Agent on the Fleet Tracker
server on each specified day of the week. The repeat interval must be at least one minute, and the
default setting is 24 hours.

Note: You can also configure the Local Printer Management Agent settings using a configuration file. For
more information, see the Local Printer Management Agent Administrator’s Guide.

5 Click Submit.

Note: You can view or export the data that Local Printer Management Agent collects from the Print Queues

tab.

Deleting data collectors

Lexmark Remote Asset Manager and Local Printer Management Agent

1 From the Fleet Tracker web portal, click Manage > Fleet > Data Collectors.

2 If necessary, select a client or group. For more information, see “Selecting a client or group” on page 16.

3 Select a data collector, and then click Data Collector > Delete.

Embedded Lexmark Remote Asset Manager

1 From the Fleet Tracker web portal, click Manage > Fleet > Data Collectors.

2 If necessary, select a client or group. For more information, see “Selecting a client or group” on page 16.

3 Select a data collector, and then click Data Collector > Delete.

4 |f the data collector is running before the deletion, then do either of the following:



Managing the fleet 28

Note: The Pending Deletion status does not delete the data collector. It only unenrolls the Embedded
Lexmark Remote Asset Manager so it does not roll up to Fleet Tracker. For more information on the
Pending Deletion status, see “Understanding data collector statuses” on page 22.

® Execute the deletion from the configuration page of the Embedded Lexmark Remote Asset Manager.

a Obtain the printer IP address. Do either of the following:
— Locate the IP address on the printer home screen.
— Viewthe IP address in the Network Overview section or in the TCP IP section of the Network/Ports

menu.

b Open a web browser, and then type the printer IP address.

¢ From the Embedded Web Server, click Settings > Apps > Embedded Lexmark Remote Asset
Manager > Configure.

d From the application configuration page, click General > Unenroll.

® Click Force Delete > OK.

Note: The server does not wait for a response from the Embedded Lexmark Remote Asset Manager
when performing this method.

Managing printer servicing

Managing policies

A policy lets you specify how ticket creation and e-mail notifications are handled for various printer-related
conditions and tasks. These events fall into three categories: service, maintenance, and supplies.

A master policy covers all printers and groups of printers, and can be customized as needed. You can also
create a custom policy for a printer or group, overriding the policy of any parent groups that the printer or group
belongs to.

Understanding policies

There are three types of policy events:

Service—Lets you specify how to handle printer conditions that require service. For example, jammed
printers and empty trays.

Maintenance—Lets you schedule maintenance activities and specify how to handle them. For example,
replacing fuser and replacing toner cartridge.

Supplies—Lets you specify how to handle supplies-related printer conditions. For example, paper out, waste
toner bottle level alert, and maintenance kit level alert.

The following table shows the policies for each policy event:



Managing the fleet

Service

Cover Open

Door Open

Device Down

Input Tray Empty

Input Tray Missing
Device Jammed
Marker Supply Missing
Device Offline

Maintenance

Clean Device

Replace Fuser

Replace Maintenance Kit
Replace Device

Replace Toner

Supplies

Maintenance Kit Level Alert
Paper Low

Paper Out

Photo Conductor Level Alert
Toner Level Alert

Toner Low

Toner Out

Toner Replaced Level Alert

Output Full Waste Toner Box Level Alert
Output Near Full ® Waste Toner Full Alert
Output Tray Missing ® Waste Toner Nearly Full Alert

Overdue Maintenance

Service Requested

You can configure what happens when each policy event is triggered using the following:

Event Scheduling—Lets you schedule a maintenance activity (by date or page count). You can also set the
event to recur.

Ticket Creation—Lets you configure when tickets are created before or after an event is triggered. You can
set the priority level, assign the ticket to a vendor, or specify if an e-mail is sent when a ticket is created or
closed.

Note: You cannot create a ticket for the Toner Replaced Level Alert policy. Only an e-mail notification can
be configured for this policy.

E-mail Notification—Lets you configure when e-mail notifications are sent before or after an event is
triggered. You can also set the notification level and add more information in the notes field.

When Fleet Tracker receives a new data rollup, printer conditions such as changes in usage or status trigger
policy events. The policy event is triggered the first time the condition is detected and is not retriggered until
the condition is resolved. So if the condition persists for subsequent rollups, then no new e-mail notifications
or tickets are generated until the condition is reset and occurs again.
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The following flowchart illustrates the life cycle of a printer condition as it applies to policy events (maintenance

events not included):

Device
condition
occurs
Data
rollup
Y Generate an
e-mail
notification or a
ticket
N
Update the
device data in

Fleet Tracker

Service the
device
or resolve the
condition

Ticket is closed
automatically
when the event
is cleared

Device policy
event is
reset

Close the ticket
manually

|

End

You can trigger policies either by date or by rollup. Scheduled maintenance policies occur at the specified date.
Rollups trigger all other policies. After the data from a rollup is saved, all newly discovered printers are evaluated
to see if any policy conditions are met. Tickets and e-mails are generated as indicated by the printer policies.
If a ticket or e-mail is generated, an internal flag is set to avoid duplicate tickets and e-mails.
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Creating a group policy
1 From the Fleet Tracker web portal, click Manage > Fleet > Policies.

2 Select a client or group. For more information, see “Selecting a client or group” on page 16.

3 Click Create Policy.

4 Customize the policy for the appropriate service, maintenance, and supply events.
5 If necessary, from the Maintenance tab, create a custom activity type.

6 Click Ok.

Creating a printer policy

1 From the Fleet Tracker web portal, click Manage > Fleet > Devices.
2 Click a printer name.

3 Click Policy > Create Policy.

4 Configure the policy for the appropriate service, maintenance, and supply events.

5 Click Ok.

Editing a policy
1 From the Fleet Tracker web portal, click Manage > Fleet > Policies.

2 If necessary, select a client or group. For more information, see “Selecting a client or group” on page 16.

Note: The policy events are organized according to their types in the Service, Maintenance, or Supplies
tabs.

3 Click the policy name, and then configure the settings.

4 Click Ok.

Managing the ticket life cycle

Tickets are generated automatically when a policy event is created. The open tickets are closed automatically
when a policy event is cleared.

Notes:

® Tickets can also be generated manually for a printer.
® Customize the data shown using the left pane filters. The filters are populated based on the search
results.

Creating a ticket manually
Note: You can create tickets manually for only one printer at a time.
1 From the Fleet Tracker web portal, click Manage > Fleet > Devices.

2 Click a printer name.
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3 Click Ticket > Create Ticket, and then enter the appropriate information.

4 Click Submit.

Editing a ticket

1 From the Fleet Tracker web portal, click Manage > Fleet > Tickets.

2 If necessary, select a client or group. For more information, see “Selecting a client or group” on page 16.

3 If necessary, click a printer name.
4 Click a ticket.

5 Configure the settings.

6 Click Submit.

Configuring the ticket life cycle

For Service and Supplies policy events, and for manually created tickets, you can send an e-mail notification
when the ticket is created or closed.

Configuring the life cycle of tickets in Policies
1 From the Fleet Tracker web portal, click Manage > Fleet > Policies.
2 Select a group, and then click a policy.

3 Click a Service or Supplies event.

4 From the Ticket tab, select Manage Tickets for [x] events, and then configure the settings.
5 Select Send E-mail on ticket creation or Send E-mail on ticket closure.

6 From the Notification tab, select the users and when to notify them.

7 Click Ok.
Configuring the life cycle of manually created tickets

1 From the Fleet Tracker web portal, click Manage > Fleet > Devices.

2 Select a group, and then click a printer name.

3 From the Ticket tab, click a ticket, and then configure the settings.

4 From the Technician Visits section, configure the settings.

5 Click Submit.

Note: For more information on manually creating tickets, see “Creating a ticket manually” on page 31.

No e-mail notifications are sent in the following cases:
®* When a ticket that is generated automatically as a result of a Maintenance policy event is closed

® \When a ticket is deleted before it is closed
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Managing data and reports

When viewing historical data by group or generate reports by group, make sure that one of the following is
selected:

® All groups containing at least one client or group
® A client containing one group as a site location
® A group containing another group
Note: A printer that was moved out of a group may be rolled up again to the same group automatically. This

instance causes two rows for the same printer to appear in the historical data or reports. The period in which
the printer is associated to a group is not captured in historical data or reports.

Understanding date ranges

When viewing the historical data or generating reports, you can select one of the following predefined date
ranges from the Time Period menu:

® Last 30 Days—Shows data from the previous 30 days until the current date
® Last 90 Days—Shows data from the previous 90 days until the current date
* Last Week—Shows data from the previous week starting on a Sunday and ending on the last Saturday
® Last Month—Shows data from the previous calendar month excluding the month of the current date
® Last Quarter—Shows data from the previous quarter excluding the quarter of the current date
® Last Year—Shows data from the previous calendar year excluding the year of the current date
* This Week—Shows data from the last Sunday until the current date
* This Month—Shows data from the first day of the current month until the current date
* This Quarter—Shows data from the first month of the current quarter until the current date
* This Year—Shows data from January 1 of the current year until the current date
® Custom Date Range—Shows data for the specified dates
For historical data, if you select an option that includes a date range in the View menu, then the data shown

for the time period changes. The historical data view covers the full weeks, months, quarters, or year that fits
into the specified time period.

For example, on October 8, a user selects Supplies by Quarter in the View menu and Last 30 days in the Time
Period menu. The period starts from September 7 and ends on October 8, which falls under the third quarter
(July to September) and fourth quarter (October to December). In this case, viewing the historical data shows
supplies data from July 1to October 8.



Managing data and reports 34

Managing reports

Understanding reports

Predefined reports
* Consumed Supplies (CSV)—Lists the supplies that were replaced for each printer within a specified period

* Days Until Empty by Current Cartridge—Lists the estimated number of days remaining until the supply is
empty for each printer based on the current cartridges

* Days Until Empty by Device Lifetime—Lists the estimated number of days remaining until the supply is
empty for each printer based on the old and current cartridges

* Days Until Empty by Device Time Span—Lists the estimated number of days remaining until the supply is
empty for each printer based on the old and current cartridges within a specified period

* Days Until Empty Summary by Current Cartridge—Shows a summary of the estimated number of days
remaining until the supply is empty based on the current cartridges

¢ Days Until Empty Summary by Device Lifetime—Shows a summary of the estimated number of days
remaining until the supply is empty based on the old and current cartridges

¢ Days Until Empty Summary by Device Time Span—Shows a summary of the estimated number of days
remaining until the supply is empty based on the old and current cartridges within a specified period

* Inventory by Group (CSV)—Lists the number of printers, the uptime percentage, and the recent percentage
of reporting printers in each group within a specified period

® Supplies by Device (CSV)—Lists the supplies usage for each printer within a specified period
* Volumes by Device (CSV)—Lists the print, copy, fax, and scan page volumes for each printer within a

specified period
Custom reports

You can create custom reports using the Pentaho Report Designer software. The following parameters are
required in every report:

® entity—The ID of the printer or group for which the report is run
®* starttimestamp—The start date of the report
®* endtimestamp—The end date of the report

The following keywords are also required to determine whether the report can be run on a group or a printer:
® device

® group

Note: For more information on creating custom reports, see the help information for the Pentaho Report
Designer software.

Generating reports
1 From the Fleet Tracker web portal, click Reports > Generate Report.

2 If necessary, select a client or group. For more information, see “Selecting a client or group” on page 16.

3 Select a predefined report.
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4 If necessary, select a time period.
5 View, export, or e-mail the report.

Note: You can edit, delete, or export current scheduled reports from the Schedule Report page. You can also
view and delete past reports from the Archived Reports page.

Scheduling reports

Note: Details of scheduled reports show the local time zone from where the client is accessing the
application.

1 From the Fleet Tracker web portal, click Reports > Schedule Report.

2 If necessary, select a client or group. For more information, see “Selecting a client or group” on page 16.

3 Click Create, and then type a name for the report.
Note: You can also edit, delete, or export current scheduled reports.
4 Select a predefined report.
5 Configure the report parameters, and the frequency of generating reports.

6 Click Schedule.

Managing report views

Lexmark  Fleet Tracker 3 0
Dashboard Manage ~ Reports ~

Historical Data > Views

Views

+ Create

View

Drumtest
Photoconductor Level
device poll test
drum2

insumo

prueba

volumes

1 From the Fleet Tracker web portal, click Reports > Historical Data.

2 If necessary, select a client or group. For more information, see “Selecting a client or group” on page 16.

3 Click Manage Views > Create.
Note: You can also edit or delete views.
4 Enter a name for the view.
5 To share the view with other Fleet Tracker users, select Shared.

6 From the Rows section, select the row and items to include.
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Notes:

® To add or remove a column, click the right or left arrows, respectively.
® To organize the order of columns, click the up or down arrows.

7 Click Save.
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Configuring server settings

1
2

3

From the Fleet Tracker web portal, click a’ > Server.

From the Server Configuration section, configure the following:

* Bind Address—The IP addresses of the server where you want the web page to be accessible. To make

all IP addresses accessible, then leave this field blank.

® Session Timeout—The number of minutes a user stays logged in to the Fleet Tracker web portal before

the connection times out.

® Server Port—When enabled, data is received in the server port. We recommend setting the port number

to 80.
Click Submit > Yes.

Note: The changes take effect after the server restarts.

Securing server communication

H W N o

From the Fleet Tracker web portal, click a’ > Server.

From the Server Security Configuration section, click Configure Server Security.
Configure the SSL certificate information.

Click Generate SSL Certificate.

Note: To sign the SSL certificate by a trusted authority, download the certificate signing request (CSR).
Sign the certificates, and then apply the vendor signed certificates.

Enable the secure port, and then enter the port number.

6 Click Save, and then let the server automatically restart.

10

Access the Fleet Tracker web portal again. For more information, see “Accessing the Fleet Tracker web

portal” on page 7.

Configure the data collectors to communicate with the LFT server using a secured port.

Click 'a' > Server.

From the Server Configuration section, clear Server Port (Non-Secured Port).

Exporting server log

Notes:

* We recommend setting the logging level to Verbose for a day or two before exporting.
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® |tis not necessary to restart the server after updating the logging level.

1 From the Fleet Tracker web portal, click 'a' > Server.
2 From the Logging section, select a log to export.
3 If necessary, select Archive log.

4 Click Export Server Log.

The logs are archived in the \\Lexmark\Fleet Tracker\server folder.

Configuring the dashboard

1 From the Fleet Tracker web portal, click a’ > Dashboard.

2 Do either of the following:
® Hide the dashboard.
® Configure the supply and ticket widgets by entering a value from 1to 30.
Notes:
® The default value for the Supply widget is 7 days.
® The default values for the Ticket widget are 7, 7, and 30 days, respectively.

3 Click Submit.

Configuring e-mail settings

Notes:

® Only super administrators can configure the e-mail settings.
® To get your e-mail server information, contact your e-mail provider. To view examples of e-mail server
settings for some common e-mail providers, see “Appendix A: Common e-mail server settings” on

page 49.

1 From the Fleet Tracker web portal, click a’ > Email Notification.

2 Configure the following:
® E-mail Server—The IP address or host name of the server used for sending e-mail.

SMTP Gateway Port—The port number used for sending e-mail. The default port number is 25.

® Username—The e-mail address used for sending e-mail.

® Password—The password for the e-mail address.

®* From: E-mail Address—The alternative e-mail address used for sending e-mail.

® Use a different e-mail address for Reply-To—Specify an alternative reply e-mail address.

3 If necessary, configure the advanced e-mail settings.

Note: Each SMTP property consists of a name-value pair.
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4 To validate the e-mail server configuration, click Test E-mail Server.

5 Click Save.

Customizing e-mail messages

Customize the content and style of the e-mail messages that the server sends as notifications. Use the velocity
templates on which the messages are based.
You can do one or more of the following:
® Add variables that tie into back-end Fleet Tracker data to populate the message with appropriate content.
® Structure your content using styles.
* Add images, such as your organization logo.

Introduce conditional logic to create dynamic messages.

For more information and tips on customizing e-mail messages using the velocity templates, see “Appendix B:
Understanding velocity e-mail templates” on page 50.

Configuring rollup by e-mail

Warning—Potential Damage: The e-mail address must be used only for the Fleet Tracker server. After an
e-mail rollup, Fleet Tracker deletes all the e-mails from the inbox, including e-mails that were sent by
Lexmark Remote Asset Manager. To protect your personal information, do not use the e-mail for other
purposes.

1 From the Fleet Tracker web portal, click a’ > Rollup by E-mail.

2 Select Enable rollup by e-mail.

3 Configure the following:
® Provider—The IP address of the e-mail provider
® Port—The port number of the e-mail provider
® Protocol—The protocol for incoming e-mails

User ID—The user name for the e-mail account
® Password—The password for the e-mail account
® Security—The security protocol for accessing e-mails

4 Configure the frequency of data sending from the e-mail to the server.

Note: When a rollup is done, e-mails are deleted from the e-mail account and only unread e-mails are
queued for the next rollup.
5 Do any of the following:
® To validate the e-mail server configuration, click Test E-mail Connection.
® To run the e-mail rollup settings, click Run Now.
® To view the e-mail rollup configuration settings, click View Rollup Log.
® To reset the settings, click Reset.

6 Click Save.
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Configuring e-automate connections

E-automate is a third-party application that helps customers manage common business processes, like
inventory control and billing. Fleet Tracker can be integrated with e-automate so that the application can use
the Fleet Tracker data.

Note: In order for the Fleet Tracker data to integrate correctly with e-automate, first configure the printer
assets in e-automate. Make sure that the e-automate asset serial number matches the printer serial number.

1 From the Fleet Tracker web portal, click a’ > System Integration.
2 Click Create.

You can also do the following:
® To search for an e-automate connection, type its name in the Find Connection field.
® To edit an e-automate connection, click its name.
* To delete an e-automate connection, select its name, and then click Delete.

3 From the e-automate Connection Details section, configure the following:
® Connection Name—The name of the e-automate connection
® Username—The user name used to log in to the e-automate server
® Password—The password used to log in to the e-automate server
® Company ID—The company ID associated with the e-automate server
® Server Address—The IP address of the e-automate server
® Port—The port number used to send Fleet Tracker data to e-automate
* Web API—The web API used with the e-automate server
® API Version—The web API version number

4 To schedule a recurring data transfer, from the Automated Transfer of Meter Data section, do the following:
a Select Transfer Enabled.
b Inthe Transfer Time field, specify the frequency for sending data.

¢ Specify the hour (0—23 in 24-hour time) and day for the transfer to occur.
5 If necessary, from the Meter Mapping section, configure the settings.
Notes:

®* Make sure that the default values have not been changed in e-automate. These values must match
the meter fields used in e-automate for the data to be integrated properly.

® |f you do not want to send meters to e-automate, then in the Enabled column, clear the meter.

* |f you want to send meters only to e-automate and it has a value other than zero, then from the Non-
Zero column, select the meter.

6 From the Group Access section, select the groups whose data is shared with e-automate over this
connection.

7 To validate the configuration, click Test Connection.

Note: When editing an e-automate connection, you may also click Send data to e-automate now to
initiate a one-time data transfer.

8 Click Save.
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Note: Failed transfers do not appear in the Last Transfer column. To identify the cause of failure, check
the error logs in the LFM.log file on the server.

Configuring user access

Add or remove users, update user information, and set up group-level access.

1 From the Fleet Tracker web portal, click 'a' > Users.

N
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Click Create.

Note: You can also search, edit, or delete users.

From the General Information section, specify the appropriate information.

From the Contact Information section, specify the appropriate information.

From the Group Access section, select the groups that you want the user to have access to.

Click Create User.

Assigning user roles

You can assign one of the following roles to a user:

Super Administrator—Super administrators have full access of the Fleet Tracker web portal, but cannot
change their own group access or delete their user account. Super administrators can also manage logging
levels, export and archive logs, and download diagnostics for the remote asset manager data collectors.

Administrator—Administrators can update user information for groups that they have access to, but cannot
add or delete super administrator accounts.

Customer Manager—Customer managers can view data and create tickets. They can also create new
historical data views and generate and schedule reports, but cannot archive the reports or share the
historical views.

Customer Viewer—Customer viewers can view the data for the groups that they have access to, but cannot
make any configuration changes. They also cannot create any historical views, reports, or tickets.

Technician—Technicians can view data and manage tickets for any groups that they have access to. They
can also edit their own general and contact information, but cannot perform any configuration tasks from
the Fleet Tracker web portal.

API—API users can only make calls to the Fleet Tracker Open API REST interface; other users cannot do
the same. Calls made to the API by API users only return the data for groups that they have access to. API
users cannot access the Fleet Tracker web portal.

The table illustrates the permissions of each user role.

Feature Super Administrator Technician Customer Customer

Dashboard tab \/ ‘/ \/ \/

Administrator Manager Viewer

Manage tab Fleet (view)

Clients

Reports tab

v v
Groups and \/ \/ \/
v v
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Feature Super Administrator Technician Customer Customer

Administrator Manager Viewer

Devices list Create \/ ‘/
Note: To navigate, click .
Manage > Fleet > Edit ‘/ ‘/
Devices. Delete \/ \/
Export \/ ‘/ \/ \/ \/
Copy v v v
Move \/ \/ \/
Remove from \/ \/
group
Default Views \/ ‘/ ‘/ \/ ‘/
Create and \/ ‘/ \/
manage
Views
Data Collectors list Create \/ \/ ‘/
Note: To navigate, click .
Manage > Fleet > Data Edit ‘/ ‘/ ‘/
Collectors. Delete ‘/ ‘/
Export \/ \/ \/ \/ \/
Import data ‘/ ‘/ \/
Default Views \/ ‘/ ‘/ \/ ‘/
Create and \/ ‘/ \/
manage
Views
Print Users Export \/ \/ \/ \/ \/
Note: To navigate, click
Manage > Fleet > Print
Users.
Print Queues Export ‘/ ‘/ ‘/ \/ ‘/
Note: To navigate, click
Manage > Fleet > Print
Queues.
Policies Create \/ \/
Note: To navigate, click
Manage > Fleet > Delete ‘/ ‘/
Policies.
Tickets Delete \/ ‘/
Note: To navigate, click
Manage > Fleet > Tickets. Export ‘/ ‘/ ‘/ ‘/ ‘/




Configuring Fleet Tracker 43

Feature Super Administrator Technician Customer Customer

Administrator Manager Viewer

Historical Data \/ ‘/ ‘/ \/ \/
Note: To navigate, click Reports >
Historical Data.
. ¢_ Server v
Settings ( ) page
Dashboard ‘/ \/
Vendors \/ ‘/
Email \/
Notification
Rollup by E- \/
mail
System \/ ‘/
Integration
Users ‘/ ‘/
Notes:

® Users of all roles are prohibited from changing their own user ID and role.

® Users of all roles can view only the data or configuration tasks for groups to which they have been given
access by a super administrator.

Managing vendor information

In Fleet Tracker, vendors are organizations that are responsible for the upkeep of your printers. Most technicians
who service your printers belong to a vendor. You can manage your vendors and assign tickets to them. Creating
vendors lets you send maintenance tickets consistently to the same organization. You can also confirm that a
specific organization is handling all the upkeep of a group of printers.
1 From the Fleet Tracker web portal, click 'a' > Vendors.
2 Click New Vendor.
Note: You can also edit the vendor information.

3 From the Vendor section, specify the appropriate information.

4 From the Branch Office section, click New Branch Office, specify the appropriate information, and then click
Ok.

5 Select or add a technician.

Note: Add technicians from the Users page before assigning them to a vendor. For more information, see
“Configuring user access” on page 41.

6 Click Submit.
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Frequently asked questions

How do | change my password?

1 From the Fleet Tracker web portal, click your user name on the upper-right corner of the page, and then
click My Account.

2 From the General Information section, change your password.

Note: Only the logged in user can change their password. After changing the password, the user is
automatically logged out of the system. On the next login, use the new password.

3 Click Save Changes.

What do | do if | forget my password?

Contact a super administrator to change your password. The password is reset to a random default, and then
shown after the password reset. We recommend setting up at least two super administrators so that they can
back each other up in editing the information of other users. If you have no super administrators set up, then
contact customer support.

My network uses Novell software products for user
authentication and printing (Micro Focus iPrint). Will the
data collectors work in this environment?

Yes. If the printers are using TCP/IP, then the data collectors get page count and status information directly from
the printers. If Windows operating system print definitions are used outside Novell software environment, then
user printing statistics can be obtained from desktops with parallel- or USB-connected printers.

What impact will the Fleet Manager components have on
the network?

The Fleet Manager components have very little impact on network bandwidth. The SNMP probes and the
returned data are a few packets at most, and the interval for polling printers and timeout settings can be
customized.

What happens to my reports after upgrading the Fleet
Tracker server?

Upgrading the Fleet Tracker server overwrites the existing predefined reports. Any customizations made to the
predefined reports are lost. Custom reports are still available after the upgrade without any additional steps.
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To avoid overwriting customized predefined reports, change the file names before upgrading the Fleet Tracker
server. You can distinguish between the predefined reports and custom reports by changing the title of the
custom reports using the Pentaho Report Designer software.

If the current database is compatible with the updated reports, then you can replace the new predefined reports
with the old customized-predefined reports.

The old reports can be found at install_path\webapps-bak-time stamp\ROOT\reports

Where install_path is the installation path for Fleet Tracker and time stamp is the time stamp for the
update.

The current reports can be found at install_path\server\webapps\ROOT\reports where install path
is the installation path for Fleet Tracker.

Note: Make sure to back up the new reports so that you can restore them if necessary.

What does it mean when the Detected Error State error
states that my printer is offline?

Lexmark Fleet Manager may mark printers as offline when they are not rolling up data for more than three days.
For example, if your data collector is configured to roll up every week, then the printer is stated as offline even
if it is on.

Can the cartridge data in the Days Until Empty reports
and in the "Toner ending in next [x] days" widget vary?

Yes. The Days Until Empty Summary by Current Cartridge and the Days Until Empty by Current Cartridge reports
calculate their data daily. The "Toner ending in next [x] days" widget calculates its data when a rollup occurs.

How does Fleet Tracker update the Embedded Lexmark
Remote Manager?

Fleet Tracker downloads the available update, stores it in the C:\Program\Files\Lexmark\Fleet Tracker
\updates\agent folder, and then the server checks the printer software version. If an outdated version is
discovered, then Fleet Tracker checks if the Embedded Lexmark Remote Asset Manager has automatic update
enabled. Ifit has, then Fleet Tracker sends a job to the Embedded Remote Asset Manager with the latest update.
The data collector updates after it reads the job.

How do | track the usage record of users?
Enable the audit log. By default, the usage record of a logged in user is not tracked.
Note: Retrieve the audit log entries from the AUDITLOG table.
1 Using a text editor, open the LFM-config.properties file from the Fleet Tracker directory.

2 Setauditlog.enabled to true.
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3 Save the file, and then restart Fleet Tracker.

How do | generate a usage record for a deleted user?

Once a user is deleted from Fleet Tracker, the usage record of that user is also deleted from most of the folders.

Why does a security vulnerability notification appear in a
banner when | log in?

The notification appears because of the following:
® The Fleet Tracker has only the non-secured port enabled.
® Both the secured and non-secured ports are enabled.
To resolve the security vulnerability, configure the Fleet Tracker server to run on secured port. We recommend

making client server communication over secured channel to ensure data privacy and to get rid of other security
vulnerabilities. For more information on configuring SSL, see “Securing server communication” on page 37.
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Troubleshooting

Cannot install the Fleet Manager components

Try one or more of the following:
Log in with administrator privileges
Make sure that the installation procedures are performed correctly
Restart the computer after installing the database component

Contact your Lexmark representative

Cannot access the Fleet Tracker web portal

Try one or more of the following:

Clear the cache and restart the web browser after upgrading Fleet Tracker

Make sure that the Fleet Tracker service is running
1 From the Fleet Tracker server, open the Windows Run dialog box, and then type services.msc.
2 From the Services window, check the status of the Lexmark Fleet Tracker service.

3 Do either of the following:
® |f the status is Started, then right-click LexmarkFleetTracker, and then click Restart.
® |f the status is not Started, then right-click LexmarkFleetTracker, and then click Start.

Contact your Lexmark representative
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Cannot upload a license file

Try one or more of the following:
Make sure that the license has not yet expired
Make sure that the license file is associated with the correct MAC address

If the number of printers in Fleet Tracker exceeds the number of allotted printers in the
license, then purchase more licenses

If you do not want to purchase more licenses, then delete some printers or change their states. For more
information, see “Understanding printer states” on page 19.

Contact your Lexmark representative

Cannot upgrade Fleet Tracker to version 311 or later

Make sure to migrate the Lexmark Fleet Tracker 2 and the Lexmark Services Monitor to the
Lexmark Remote Asset Manager

For more information, see the Migration to LRAM White Paper.

Make sure to remove the Lexmark Fleet Tracker 2 and the Lexmark Services Monitor from
the Fleet Tracker web portal

Make sure to uninstall the Lexmark Fleet Tracker 2 and the Lexmark Services Monitor

Contact your Lexmark representative
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Appendices

Appendix A: Common e-mail server settings

E-mail providers usually recommend the following e-mail server settings for configuring outgoing e-mail with
their services.

Notes:
* E-mail providers may change these settings at any time. Make sure that the configurations are still valid
before implementing them in Fleet Tracker.
® These settings may vary for your particular e-mail setup.

® E-mail providers may require the From e-mail address to match the e-mail address of the account to
avoid sending spam e-mails.

Gmail

® SMTP Gateway—smtp.gmail.com
® SMTP Gateway Port—465

® UserID

® Password

Gmail SMTP properties

Name Value

mail.smtp.auth true
mail.smtp.socketFactory.port 465
mail.smpt.socketFactory.class javax.net.ssl.SSLSocketFactory
mail.smtp.socketFactory.fallback false

Outlook

* SMTP Gateway—smtp.live.com
® SMTP Gateway Port—587

® UserID

® Password

Outlook SMTP properties

mail.smtp.starttls.enable true
mail.smtp.port 587 J
Yahoo Mail

® SMTP Gateway—smtp.mail.yahoo.com
® SMTP Gateway Port—465 or 587
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® UserlID
® Password

Yahoo Mail SMTP properties

Name Value

mail.smtp.auth true
mail.smtp.socketFactory.port 465
mail.smpt.socketFactory.class javax.net.ssl.SSLSocketFactory
mail.smtp.socketFactory.fallback false

Appendix B: Understanding velocity e-mail templates

Velocity is a presentation language, similar to JavaServer Pages (JSP), that allows for much flexibility. It lets you
mix HTML and velocity tags so that you can craft dynamic e-mail content and styles for your notifications. You
can modify the message templates and can use any functionality that velocity makes available.

Variables are accessed in velocity files in the following format: $

{ objects.device.manufacturerName }.Inthis example, objects isthe top-level objectand device
is its child. manufacturerName is the actual variable or property in the objects.device object that is
returned.

Here are some helpful tips for customizing notifications using velocity.

® Some e-mail providers, such as Gmail™ webmail service, may ignore HTML styles that are included in the
velocity templates. But if the HTML styles are embedded inline, then they are honored.

® [f you are not sure whether an object is null, then use an "if/else" clause to check it before you show it. Or
include the following logic in the variable statement: ${ ticket?.technician?.displayname }.This
logic ensures that if the ticket and technician objects are not null, then the display name field is returned.

Updating velocity templates

The velocity templates used to generate e-mail messages come preconfigured on the Fleet Tracker server in
the install_path\server\webapps\ROOT\WEB-INF\classes\emails directory. To customize the e-mail
notifications that Fleet Tracker sends, update the velocity files accordingly.

1 Access the Fleet Tracker server, and then navigate to install_path\server\webapps\ROOT\WEB-INF
\classes\emails.

2 Open the velocity template that you want to update, make the necessary changes, and then save the file.

Note: To revert to predefined templates at a later time, make sure to keep backup copies of the
templates.

If the Fleet Tracker server detects changes in the templates, then it recompiles the velocity files. The next e-mail
notification it sends uses the updated template.

There are five predefined templates that Fleet Tracker uses to generate e-mail notifications. Each template has
some specific objects associated with it and objects that are common across all templates that you can use to
customize the content. The rest of this topic outlines what each template is used for and the data items that
are available for them.
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The following objects are common across all the velocity e-mail templates:

¢ dictionary—This object is used internally to translate text strings, primarily field names, into the appropriate
localized text. There are no predefined child objects; instead, the developer defines them and they vary
based on the implementation. This object is an extension to the strings that appear in /i18n/index_
$language.properties, where language is a language code, such as "en" or "de."

® objects—This object contains the "theme objects" of the e-mail (such as objects.device and objects.policy).
Most of the data items that you use in the notifications are found in this object.

* host—This object contains the host name and host IP address of the server sending the e-mail. To access
the fields, use "host.hostAddress" for the IP address and "host.hostName" for the host name.

The PolicyGroupEvent_language.vm template is used to generate e-mail notifications for policy events, as
configured in the printer policy. The following objects can be used in this template:

Object Property Data Type Description
objects.device .manufacturerName | String Name of printer manufacturer.
.modelName String Model name of the printer.
.serialNumber String Serial number of the printer.
.contactName String Name of the contact for the printer.
.name String Friendly name of the printer.
.ipAddress String IP address of the printer.
.colorCapable boolean Returns true if the printer is color capable.
.accountCode String The client the printer belongs to.
tickets array of Objects Contains all tickets associated with the printer.

Each Object exposes the following properties:
® details (String)

® dateCreated (Date)

* lastUpdated (Date)

® dueDate (Date)

® dueTime (Date)

® technician (Object)

¢ technician.displayName (String)
® ticketld (String)

® status (String)

® _priority (String)

.port Object Exposes the .type (String) property.

JlastDataCollection |Date The last time rollup data was received from the
printer.

.macAddress String MAC address of the printer.

.dnsHostName String DNS host name of the printer.

.assetTag String An optional identifier field; may be null.

firmware String Current version of firmware installed on the
printer.

.engineCode String Engine firmware level of the printer.
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Property Data Type Description

objects.policy .problem String The event that triggered the policy notification.

The PolicyGroupEvent_language.vm template is used to generate e-mail notifications for policy events, as
defined in the group policy. The following objects can be used in this template:

Object Property Data Type Description
objects.group .name String Name of the group
.notes String Informational text associated with the group
.accountCode String Account code of the group
.address1 String The first line of the address where the group is
located
.address2 String The second line of the address where the group
is located
.city String The city where the group is located
.province String The province where the group is located
.postalCode String The postal code for the group
.country String The country where the group is located
.email String The e-mail address associated with the group
telephone String The telephone number associated with the
group
fax String The fax number associated with the group
.contact String The name of the group contact
.contactPhone String The telephone number of the group contact
.contactEmail String The e-mail address of the group contact
objects.policy .problem String The event that triggered the policy notification

The CostForGroupExpiration_language.vm template is used to generate e-mail notifications for contract
expiration at the group level. The CostForDeviceExpiration_language.vm template is used to generate e-mail
notifications for contract expiration at the printer level. The following objects can be used in both of these
templates:
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Object Property Data Type Description
objects.costs .purchaseOrder String Identifier to track the actual purchase order for
the specific group or printer.
.acquisitionDate Date Date of acquisition in MM/DD/YYYY format.
.acquisitionType String Type can be "Purchase," "Lease," or "Rental."
.puchaseOption float Used to keep buyout price.
.initialPayment float Initial payment.
finalPayment float Final payment.
.monthlyPayment |float Monthly payment.
.numberOfPayment | Integer Total number of payments.
s
.expirationNoticeD |Date Date of expiration of the contract in
ate MM/DD/YYYY format.
.emailNotification String E-mail address associated with the selected user.
.bwAllowances Integer Number of allotted black-and-white pages.
.colorAllowances Integer Number of allotted color pages.
.bwRatePerPage float Price per black-and-white page.
.colorRatePerPage |float Price per color page.
.bwOverage float Overage price per black-and-white page.
.colorOverage float Overage price per color page.
.maintenancePaym | String Maintenance payment can be "Annually,"
ent "Monthly," "Quarterly," or "Cost Per Page."
.maintenanceCost |float Maintenance cost.

objects.group

An object that, along with all its child objects, is
available for
CostsForGroupExpiration_language.vm.

objects.device

An object that, along with all its child objects, is
available for
CostsForDeviceExpiration_language.vm.

The final velocity template available for customization is ReportEmail_language.vm, which is used to generate
messages when reports are e-mailed. Fleet Tracker lets users print transparencies and does not make any
objects available for this template. But users can still structure the style and presentation of the e-mail using

velocity.

The following velocity example shows how to filter data by using conditional logic. The e-mail message shows
information about tickets that are created or updated as a result of the printer alert, as determined by the time
stamps. This example can be useful when a policy event triggers ticket creation, ticket changes, or e-mail

notifications.

Name: $!objects.dataCollector.name

$lobjects.dataCollector.address
Slobjects.dataCollector.accountCode

#if (Sobjects.dataCollector.group) #if
(Sobjects.dataCollector.group.class_ ==
"com.lexmark.lfm.domain.Group")$!objects.dataCollector.group.name

Address:
Company Code:
Site Location/Group:
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#else<br>

#end

#else<br>

#end
Enrollment Code:<b>$!objects.dataCollector.enrollmentCode</b>
City: $!objects.dataCollector.city
State/Province: $!objects.dataCollector.province
Zip/Postal Code: S$!objects.dataCollector.postalCode
Country: $!objects.dataCollector.country
Telephone: $!objects.dataCollector.telephone
Facsimile: $!objects.dataCollector.group.fax
Website: $!objects.dataCollector.group.website
E-mail: $!objects.dataCollector.email

Contact Person:

Name: $!objects.dataCollector.contact
Telephone: $!objects.dataCollector.contactPhone
E-mail: S$S!objects.dataCollector.contactEmail

Appendix C: Understanding the Access Mode values

OPEN Remote Asset Manager is accessible.
LOCALHOST Remote Asset Manager is accessible only from the localhost machine.
PASSWORD Remote Asset Manager is accessible in the network and requires a password.

LOCALHOST_PASSWORD | Remote Asset Manager is accessible only from the localhost machine and requires a
password.

Note: The Access Mode value may be blank if the Remote Asset Manager is an older version or if the status
update is pending from Lexmark Fleet Tracker 3 or later.

Appendix D: List of supported ports

Lexmark Fleet Tracker 3 or later ports and their descriptions

Traffic Port number Protocol Port state IP address

Inbound 80 TCP Listening N/A

Inbound 443 TCP Listening N/A

Inbound 2722 TCP Listening N/A

Outbound 1521 TCP On demand IP address of the database

Lexmark Fleet Tracker 2 ports and their descriptions

Traffic Port number Protocol Port state IP address
Inbound 80 TCP Listening N/A
Inbound 443 TCP Listening N/A
Inbound 2090 TCP Listening N/A
Inbound 2722 TCP Listening N/A
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Traffic Port number Protocol Port state IP address

Outbound 80 TCP On demand IP address of Lexmark Fleet Tracker 3
Outbound 443 TCP On demand IP address of Lexmark Fleet Tracker 3
Outbound 161 TCP or UDP On demand Any IP address

Outbound 9300 TCP or UDP On demand Any IP address

Outbound 1521 TCP On demand IP address of the database

Oracle Database ports and their descriptions

Traffic Port number Protocol Port state IP address

Inbound 1521 TCP Listening N/A

Lexmark Services Monitor ports and their descriptions

Traffic Port number Protocol Port state IP address

Inbound 2070 TCP Listening N/A

Outbound 80 TCP On demand IP address of Lexmark Fleet Tracker 3
Outbound 443 TCP On demand IP address of Lexmark Fleet Tracker 3
Outbound 80 TCP On demand IP address of Lexmark Fleet Tracker 2
Outbound 443 TCP On demand IP address of Lexmark Fleet Tracker 2
Outbound 161 TCP or UDP On demand Any IP address

Outbound 9300 TCP or UDP On demand Any IP address

Open API

The Fleet Tracker Open APl enables you to retrieve Fleet Tracker data programmatically using a REST interface.
The API provides predefined calls for retrieving specific information. You can format the returned data to either
JSON or XML. Using the API provides flexibility and allows you to integrate the data collected by the Fleet
Tracker with your existing systems.

Appendix E: Open API users

To make calls to the API, make sure that you have a valid APl user account. A super administrator can create
APl user accounts from the Fleet Tracker web portal. When API users are created, the super administrator must
specify the credentials and group access of the users. For more information on adding API users, see
“Configuring user access” on page 41.

Appendix F: Open API calls
Calls to the Open API are made in HTML in the following format:

http://<server>/com.lexmark.lfm.api/<format>/<method>?<parameterl
name>=<parameterl value>&<parameter2 name>=<parameter2 value>
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Where:

* <server> is the host name, IP address, or domain name of the Fleet Tracker server.

® <format> specifies whether the return data is formatted to either JSON or XML.

* <method> is the API call that determines what data is returned.

® <parameter name> is the name of the parameter for the API call.

® <parameter value> is the value of the parameter.
The Open API expects seven calls from the client. When the client initiates any of the seven calls, it returns with
Fleet Tracker data in the specified format. All calls require authentication except for the 1icensed and

version calls. The Open API follows the group access that is configured per API user. If a user does not have
group access, then the group and its device information are not returned for any of the user’s API calls.

Exceptions

Method Description

licensed |/com.lexmark.lfm.api/<format>/licensed | POST |If the Fleet Tracker is using a valid license, then this
call returns a true value. Otherwise, the call returns
a false value.

Tracker that is installed on the server.

version |/com.lexmark.Ifm.api/<format>/version |POST | This call returns the current version of the Fleet }

Appendix G: Understanding methods

Method Return value Parameters Example HTML Notes

client This call returns a list of | None http://<server>/com.| |Ifthere are no clients, then
client details, one per exmark.Ifm.api/<form | no Client Details is
client. at>/client returned.

Each record includes
the following:

® Clientld
® ClientName
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Method Return value Parameters Example HTML Notes
getprinter |Thiscallreturnsalistof| e clientid, ® http://localhost/c If clientid or clientname is
sforclient |printer details. clientname, or both om.lexmark.lfm.a |invalid, or there are no
Each printer record (required) pi/xml/getprinters | devices for the specified
includes the following: | e start (optional) forclient? client, then no Printer
lientname=lexm |Details is returned.
® AssetTa ® |imi i ¢
9 limit (optional) ark&start=2&limit
® Firmware =5
* IsManaged ® http://localhost/c
® |[PAddress om.lexmark.lfm.a
e | ocation pi/xml/getprinters
forclient?
[ ]
MACAddress clientid=eSF&star
® ModelName t=2&Ilimit=5
¢ Port e http://localhost/c
® Printerld om.lexmark.lfm.a
e PrinterName pi/xml/getprinters
forclient?
® SerialNumber . _
clientname=lexm
ark&clientid=eSF
&start=2&limit=5
getprinter |Thiscallreturnsalistof| e clientid, http://localhost/com.| | If clientid or clientname is
counthisto |printer count record clientname, or both | exmark.lfm.api/<form | invalid, or there are no
ryforclien |details. If the start and (required) at>/getprintercounthi | devices for the specified
t end times are storyforclient? client, then no

specified, then there is
one record per device
that exists during the
specified time range.
The details are for the
most recent rollup
within the period. If a
period is not specified,
then the current
device information is
returned with one
record per device.

Each printer count
record includes the
following:

® ColorOversizeCou
nt

® ColorCount

® LifeCount

® LifeOversizeCount
® MonoCount

® MonoOversizeCou
nt

® Printerld
® ScanTime

® endtime (optional)
® |imit (optional)
® start (optional)
® starttime (optional)

clientid=eSF&starttim
e=01-01-18%2000:00

00&endtime=01-01-2
0%2000:00:00

PrinterCountRecordDetail
s is returned.
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Method Return value Parameters Example HTML Notes
getprinter |Thiscallreturnsalistof| e clientid, http://localhost/com.| | If clientid or clientname is
statushist |printer status details. If clientname, or both | exmark.Ifm.api/<form | invalid, or there are no
oryforclie |[thestartandendtimes (required) at>/getprinterstatush | devices for the specified
nt are specified, then . istoryforclient? client, then no

there is one record per
device for each rollup
that occurred during
the specified period. If
a period is not
specified, then the
current device
information is returned
with one record per
device.

Each printer status
record includes the
following:

® DetectedErrorStat
e

® DeviceStatus

® Location

® Printerld

® PrinterStatus

® ScanTime

® StatusDescription
® SystemStatus

endtime (optional)
limit (optional)
start (optional)
starttime (optional)

clientname=lexmark
&starttime=01-01-1
8%2000:00:00&end
time=01-01-20%2000
:00:00

PrinterStatusDetails is
returned.
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Method Return value Parameters Example HTML Notes
getprinter |Thiscallreturnsalistof| e clientid, http://localhost/com.| | If clientid or clientname is
supplyhist |printer supply details. clientname, or both | exmark.Ifm.api/<form | invalid, or there are no
oryforclie |Ifthe start and end (required) at>/getprintersupply |devices for the specified
nt times are specified, e endtime (optional) hi§toryforclient? clignt, then no .
then there is one o ) clientname=lexmark | PrinterSupplyDetails is
record per supply for * limit (optional) &clientid=eSF&startti | returned.
each rollup that ® start (optional) me=01-01-18%2000:
occurred during the e starttime (optional) | 00:00&endtime=01-
specified period. If a 01-20%2000:00:00

period is not specified,
then there is one
record per supply.

Each printer supply
record includes:

® Capacity

® Color

® | evelRemaining

® LifetimeCoverage

® PercentageRemain
ing

® Printerld

® SerialNumber

® ScanTime

® SupplyType

® SupplyTypeDescri
ption

® SupplyName

® SupplyUnit

Appendix H: Open API call sample code

The following sample Java code shows how to connect programmatically and authenticate to the Fleet Tracker
Open API. The code depends on the Apache HTTP Client. Download the client from the Apache Server, and
then add it to the JAR location at the appropriate class path.

The following JAR files are required to build the sample code:

commons-codec-1.6.jar
commons-logging-1.1.1.jar
fluent-hc-4.2.3 jar
httpclient-4.2.3.jar
httpclient-cache-4.2.3 jar
httpcore-4.2.2 jar
httpmime-4.2.3.jar

This code is specific to a Fleet Tracker server using HTTP and does not work with SSL.

Note: There are comments in the code to help clarify what is happening.
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package com

import
import
import

import
import
import
import
import
import
import
import
import
import
import
import
import
import

public

java.
java.
java.

org.
org.
org.
org.
org.
org.
org.
org.
org.
org.
org.
org.
org.
org.

.lexmark.1lfm;

apache.
apache.
apache.
apache.
apache.
apache.
apache.
apache.
apache.
apache.
apache.
apache.
apache.
apache.

http.
http.
http.
http.
http.
http.
http.
http.
http.
http.
http.
http.
http.
http.

io.IOException;
util.ArraylList;
util.Llist;

Consts;

HttpEntity;

HttpResponse;

NameValuePair;
client.ClientProtocolException;
client.ResponseHandler;
client.entity.UrlEncodedFormEntity;
client.methods.HttpGet;
client.methods.HttpPost;
cookie.Cookie;
impl.client.BasicResponseHandler;
impl.client.DefaultHttpClient;
message.BasicNameValuePair;
util.EntityUtils;

class OpenAPIClient {

public static void main(String[] args){

if(args.length >= 1){

DefaultHttpClient openApiHttpClient = new DefaultHttpClient();

try {

String serverIP = args[0];

String loginURI = "http://" + serverIP + "/login/auth";
HttpGet loginGetRequest = new HttpGet(loginURI);

System.out.println("Initiating Login form GET Request");
HttpResponse serverResponse = openApiHttpClient.execute(loginGetRequest);
HttpEntity entity = serverResponse.getEntity();

System.out.println("Server response:");
System.out.println(serverResponse.getStatusLine());
EntityUtils.consume(entity);

ResponseHandler<String> responseHandler = new BasicResponseHandler();

List<Cookie> cookies = openApiHttpClient.getCookieStore().getCookies();
System.out.println("Initial set of cookies:");

if (cookies.isEmpty()) {
System.out.println("None");

} else {

for (int i = @; i < cookies.size(); i++) {

}

}

System.out.println("- " + cookies.get(i).toString());

System.out.println("Initiating Spring Security Authentication");
String authURI = "http://" + serverIP + "/j_spring_security_check?";
HttpPost sysAuthPostRequest = new HttpPost(authURI);// +

// Provide valid API User ID and Password.

List <NameValuePair> nvps = new ArraylList <NameValuePair>();
nvps.add(new BasicNameValuePair("j_username", "api"));
nvps.add(new BasicNameValuePair("j_password", "api"));

sysAuthPostRequest.setEntity(new UrlEncodedFormeEntity(nvps, Consts.UTF_8));

serverResponse = openApiHttpClient.execute(sysAuthPostRequest);
entity = serverResponse.getEntity();

System.out.println("Server Response:

+ serverResponse.getStatusLine());

EntityUtils.consume(entity);

System.out.println("Post logon cookies:");
cookies

= openApiHttpClient.getCookieStore().getCookies();
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if (cookies.isEmpty()) {
System.out.println("None");
} else {
for (int i = @; i < cookies.size(); i++) {
System.out.println("- " + cookies.get(i).toString());

}

String versionURI = "http://" + serverIP + "/com.lexmark.lfm.api/xml/version";

String clientURI = "http://" + serverIP + "/com.lexmark.lfm.api/xml/client";
// Using hard coded clientid "LXK".

String getprintersforclientwithID = "http://" + serverIP +

"/com.lexmark.1lfm.api/xml/getprintersforclient?clientid=LXK&start=0&1imit=10";

String getprintersforclientwithName = "http://" + serverIP +
"/com.lexmark.1lfm.api/xml/getprintersforclient?clientname=1exmark&start=0&1limit=10";

String getprintersforclientwithBoth = "http://" + serverIP +
"/com.lexmark.1lfm.api/xml/getprintersforclient?clientname=1exmark&clientid=eSF&start=0&1limit=10";

HttpPost verRequestPost = new HttpPost(versionURI);

HttpPost clientRequestPost = new HttpPost(clientURI);

HttpPost getprintersforclientidRequestPost = new HttpPost(getprintersforclientwithID);
HttpPost getprintersforclientnameRequestPost = new HttpPost(getprintersforclientwithName);
HttpPost getprintersforwithBothRequestPost = new HttpPost(getprintersforclientwithBoth);

String responseBody = "";

// Initiate the version API call. The version API call does not require

// authentication, so it will be always successful.
System.out.println("Initiating ver API Call");

responseBody = openApiHttpClient.execute(verRequestPost, responseHandler);
System.out.println("Server Response:");

System.out.println(responseBody);

// Initiate the client API call. If the login credentials are wrong, then

// an exception will be thrown and the call will fail.
System.out.println("Initiating client API Call");

responseBody = openApiHttpClient.execute(clientRequestPost, responseHandler);
System.out.println("Server Response:");

System.out.println(responseBody);

System.out.println("Initiating getprintersforclient with clientId API Call");

responseBody = openApiHttpClient.execute(getprintersforclientidRequestPost,
responseHandler);

System.out.println("Server Response:");

System.out.println(responseBody);

System.out.println("Initiating getprintersforclient with clientName API Call");

responseBody = openApiHttpClient.execute(getprintersforclientnameRequestPost,
responseHandler);

System.out.println("Server Response:");

System.out.println(responseBody);

System.out.println("Initiating getprintersforclient with clientId and clientName API Call");

responseBody = openApiHttpClient.execute(getprintersforwithBothRequestPost,
responseHandler);

System.out.println("Server Response:");

System.out.println(responseBody);

} catch(ClientProtocolException protocolEx){
protocolEx.printStackTrace();
} catch(IOException ioEx){
ioEx.printStackTrace();
} finally {
// When HttpClient instance is no longer needed,
// shut down the connection manager to ensure
// immediate deallocation of all system resources
openApiHttpClient.getConnectionManager().shutdown();
}



Notices 62

Notices

Edition notice

March 2021

The following paragraph does not apply to any country where such provisions are inconsistent with local
law: LEXMARK INTERNATIONAL, INC., PROVIDES THIS PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY
KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of
express or implied warranties in certain transactions; therefore, this statement may not apply to you.

This publication could include technical inaccuracies or typographical errors. Changes are periodically made
to the information herein; these changes will be incorporated in later editions. Improvements or changes in the
products or the programs described may be made at any time.

References in this publication to products, programs, or services do not imply that the manufacturer intends to
make these available in all countries in which it operates. Any reference to a product, program, or service is
not intended to state or imply that only that product, program, or service may be used. Any functionally
equivalent product, program, or service that does not infringe any existing intellectual property right may be
used instead. Evaluation and verification of operation in conjunction with other products, programs, or services,
except those expressly designated by the manufacturer, are the user’s responsibility.

For Lexmark technical support, go to http://support.lexmark.com.

For information on Lexmark's privacy policy governing the use of this product, go to
www.lexmark.com/privacy.

For information on supplies and downloads, go to www.lexmark.com.

© 2010 Lexmark International, Inc.

All rights reserved.

GOVERNMENT END USERS

The Software Program and any related documentation are "Commercial Items," as that term is defined in 48
C.F.R. 2101, "Computer Software" and "Commercial Computer Software Documentation," as such terms are
used in 48 C.F.R.12.212 or 48 C.F.R. 2277202, as applicable. Consistent with 48 C.F.R. 12.212 or 48 C.F.R.
2277202-1through 227.7207-4, as applicable, the Commercial Computer Software and Commercial Software
Documentation are licensed to the U.S. Government end users (a) only as Commercial ltems and (b) with only
those rights as are granted to all other end users pursuant to the terms and conditions herein.

Trademarks

Lexmark and the Lexmark logo are trademarks or registered trademarks of Lexmark International, Inc. in the
United States and/or other countries.

Google Chrome and Gmail are trademarks of Google LLC.
Oracle and Java are registered trademarks of Oracle and/or its affiliates.

PENTAHO is a registered trademark of Pentaho, Inc.


http://support.lexmark.com
http://www.lexmark.com/privacy
http://www.lexmark.com
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All other trademarks are the property of their respective owners.

LEXMARK SOFTWARE LICENSE AGREEMENT

PLEASE READ CAREFULLY BEFORE INSTALLING AND/OR USING THIS SOFTWARE: This Software License
Agreement ("License Agreement") is a legal agreement between you (either an individual or a single entity) and
Lexmark International, Inc. ("Lexmark") that, to the extent your Lexmark product or Software Program is not
otherwise subject to a written software license agreement between you and Lexmark or its suppliers, governs
your use of any Software Program installed on or provided by Lexmark for use in connection with your Lexmark
product. The term "Software Program" includes machine-readable instructions, audio/visual content (such as
images and recordings), and associated media, printed materials and electronic documentation.

BY USING AND/OR INSTALLING THIS SOFTWARE, YOU AGREE TO BE BOUND BY ALL THE TERMS AND
CONDITIONS OF THIS LICENSE AGREEMENT. IF YOU DO NOT SO AGREE, DO NOT INSTALL, COPY,
DOWNLOAD, OR OTHERWISE USE THE SOFTWARE PROGRAM. IF YOU DO NOT AGREE WITH THE TERMS
OF THIS LICENSE AGREEMENT, PROMPTLY RETURN THE PRODUCT UNUSED AND REQUEST A REFUND OF
THE AMOUNT YOU PAID. IF YOU ARE INSTALLING THIS SOFTWARE PROGRAM FOR USE BY OTHER PARTIES,
YOU AGREE TO INFORM THE USERS THAT USE OF THE SOFTWARE PROGRAM INDICATES ACCEPTANCE
OF THESE TERMS.

1 STATEMENT OF LIMITED WARRANTY. Lexmark warrants that the media (e.g., diskette or compact disk) on
which the Software Program (if any) is furnished is free from defects in materials and workmanship under
normal use during the warranty period. The warranty period is ninety (90) days and commences on the date
the Software Program is delivered to the original end-user. This limited warranty applies only to Software
Program media purchased new from Lexmark or an Authorized Lexmark Reseller or Distributor. Lexmark
will replace the Software Program should it be determined that the media does not conform to this limited
warranty.

2 DISCLAIMER AND LIMITATION OF WARRANTIES. EXCEPT AS PROVIDED IN THIS LICENSE AGREEMENT
AND TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, LEXMARK AND ITS SUPPLIERS
PROVIDE THE SOFTWARE PROGRAM "AS IS" AND HEREBY DISCLAIM ALL OTHER WARRANTIES AND
CONDITIONS, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, TITLE, NON-
INFRINGEMENT, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, AND ABSENCE OF
VIRUSES, ALL WITH REGARD TO THE SOFTWARE PROGRAM. This Agreement is to be read in conjunction
with certain statutory provisions, as that may be in force from time to time, that imply warranties or conditions
or impose obligations on Lexmark that cannot be excluded or modified. If any such provisions apply, then
to the extent Lexmark is able, Lexmark hereby limits its liability for breach of those provisions to one of the
following: replacement of the Software Program or reimbursement of the price paid for the Software
Program.

3 LICENSE GRANT. Lexmark grants you the following rights provided you comply with all terms and conditions
of this License Agreement:

a Use. You may Use one copy of the Software Program. The term "Use" means storing, loading, installing,
executing, or displaying the Software Program. If Lexmark has licensed the Software Program to you for
concurrent use, you must limitthe number of authorized users to the number specified in your agreement
with Lexmark. You may not separate the components of the Software Program for use on more than one
computer. You agree that you will not Use the Software Program, in whole or in part, in any manner that
has the effect of overriding, modifying, eliminating, obscuring, altering or de-emphasizing the visual
appearance of any trademark, trade name, trade dress or intellectual property notice that appears on
any computer display screens normally generated by, or as a result of, the Software Program.

b Copying. You may make one (1) copy of the Software Program solely for purposes of backup, archiving,
or installation, provided the copy contains all of the original Software Program's proprietary notices. You
may not copy the Software Program to any public or distributed network.
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¢ Reservation of Rights. The Software Program, including all fonts, is copyrighted and owned by Lexmark
International, Inc. and/or its suppliers. Lexmark reserves all rights not expressly granted to you in this
License Agreement.

d Freeware. Notwithstanding the terms and conditions of this License Agreement, all or any portion of the
Software Program that constitutes software provided under public license by third parties ("Freeware")
is licensed to you subject to the terms and conditions of the software license agreement accompanying
such Freeware, whether in the form of a discrete agreement, shrink-wrap license, or electronic license
terms at the time of download. Use of the Freeware by you shall be governed entirely by the terms and
conditions of such license.

4 TRANSFER. You may transfer the Software Program to another end-user. Any transfer must include all
software components, media, printed materials, and this License Agreement and you may not retain copies
of the Software Program or components thereof. The transfer may not be an indirect transfer, such as a
consignment. Prior to the transfer, the end-user receiving the transferred Software Program must agree to
all these License Agreement terms. Upon transfer of the Software Program, your license is automatically
terminated. You may not rent, sublicense, or assign the Software Program except to the extent provided in
this License Agreement.

5 UPGRADES. To Use a Software Program identified as an upgrade, you must first be licensed to the original
Software Program identified by Lexmark as eligible for the upgrade. After upgrading, you may no longer
use the original Software Program that formed the basis for your upgrade eligibility.

6 LIMITATION ON REVERSE ENGINEERING. You may not alter, reverse engineer, reverse assemble, reverse
compile or otherwise translate the Software Program, except as and to the extent expressly permitted to
do so by applicable law for the purposes of inter-operability, error correction, and security testing. If you
have such statutory rights, you will notify Lexmark in writing of any intended reverse engineering, reverse
assembly, or reverse compilation. You may not decrypt the Software Program unless necessary for the
legitimate Use of the Software Program.

7 ADDITIONAL SOFTWARE. This License Agreement applies to updates or supplements to the original
Software Program provided by Lexmark unless Lexmark provides other terms along with the update or
supplement.

8 LIMITATION OF REMEDIES. To the maximum extent permitted by applicable law, the entire liability of
Lexmark, its suppliers, affiliates, and resellers, and your exclusive remedy shall be as follows: Lexmark will
provide the express limited warranty described above. If Lexmark does not remedy defective media as
warranted, you may terminate your license and your money will be refunded upon the return of all of your
copies of the Software Program.

O LIMITATION OF LIABILITY. To the maximum extent permitted by applicable law, for any claim arising out of
Lexmark's limited warranty, or for any other claim whatsoever related to the subject matter of this Agreement,
Lexmark's liability for all types of damages, regardless of the form of action or basis (including contract,
breach, estoppel, negligence, misrepresentation, or tort), shall be limited to the greater of $5,000 or the
money paid to Lexmark or its authorized remarketers for the license hereunder for the Software Program
that caused the damages or that is the subject matter of, or is directly related to, the cause of action.

IN NO EVENT WILL LEXMARK, ITS SUPPLIERS, SUBSIDIARIES, OR RESELLERS BE LIABLE FOR ANY
SPECIAL, INCIDENTAL, INDIRECT, EXEMPLARY, PUNITIVE, OR CONSEQUENTIAL DAMAGES (INCLUDING
BUT NOT LIMITED TO LOST PROFITS OR REVENUES, LOST SAVINGS, INTERRUPTION OF USE OR ANY
LOSS OF, INACCURACY IN, OR DAMAGE TO, DATA OR RECORDS, FOR CLAIMS OF THIRD PARTIES, OR
DAMAGE TO REAL OR TANGIBLE PROPERTY, FOR LOSS OF PRIVACY ARISING OUT OR IN ANY WAY
RELATED TO THE USE OF OR INABILITY TO USE THE SOFTWARE PROGRAM, OR OTHERWISE IN
CONNECTION WITH ANY PROVISION OF THIS LICENCE AGREEMENT), REGARDLESS OF THE NATURE
OF THE CLAIM, INCLUDING BUT NOT LIMITED TO BREACH OF WARRANTY OR CONTRACT, TORT
(INCLUDING NEGLIGENCE OR STRICT LIABILITY), AND EVEN IF LEXMARK, OR ITS SUPPLIERS, AFFILIATES,
OR REMARKETERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, OR FOR ANY CLAIM
BY YOU BASED ON A THIRD-PARTY CLAIM, EXCEPT TO THE EXTENT THIS EXCLUSION OF DAMAGES IS
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DETERMINED LEGALLY INVALID. THE FOREGOING LIMITATIONS APPLY EVEN IF THE ABOVE-STATED
REMEDIES FAIL OF THEIR ESSENTIAL PURPOSE.

TERM. This License Agreement is effective unless terminated or rejected. You may reject or terminate this
license at any time by destroying all copies of the Software Program, together with all modifications,
documentation, and merged portions in any form, or as otherwise described herein. Lexmark may terminate
your license upon notice if you fail to comply with any of the terms of this License Agreement. Upon such
termination, you agree to destroy all copies of the Software Program together with all modifications,
documentation, and merged portions in any form.

TAXES. You agree that you are responsible for payment of any taxes including, without limitation, any goods
and services and personal property taxes, resulting from this Agreement or your Use of the Software
Program.

LIMITATION ON ACTIONS. No action, regardless of form, arising out of this Agreement may be brought by
either party more than two years after the cause of action has arisen, except as provided under applicable
law.

APPLICABLE LAW. This Agreement is governed non-exclusively by the laws of the country in which you
acquired the Software Program (or, if that country has a federal system of government, then this Agreement
will be governed by the laws of the political subdivision in which you acquired the Software). If you acquired
the Software in the United States, the laws of the Commonwealth of Kentucky shall govern. No choice of
law rules in any jurisdiction will apply.

UNITED STATES GOVERNMENT RESTRICTED RIGHTS. The Software has been developed entirely at private
expense and is provided with RESTRICTED RIGHTS. Use, duplication and disclosure by the Government is
subject to restrictions as set forth in subparagraph (c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS 252.227-7013 and in similar FAR provisions (or any equivalent agency regulation
or contract clause).

CONSENT TO USE OF DATA. You agree that Lexmark, its affiliates, and agents may collect and use
information you provide in relation to support services performed with respect to the Software Program and
requested by you. Lexmark agrees not to use this information in a form that personally identifies you except
to the extent necessary to provide such services.

EXPORT RESTRICTIONS. You may not (a) acquire, ship, transfer, or reexport, directly or indirectly, the
Software Program or any direct product therefrom, in violation of any applicable export laws or (b) permit
the Software Program to be used for any purpose prohibited by such export laws, including, without
limitation, nuclear, chemical, or biological weapons proliferation.

CAPACITY AND AUTHORITY TO CONTRACT. You represent that you are of the legal age of majority in the
place you sign this License Agreement and, if applicable, you are duly authorized by your employer or
principal to enter into this contract.

ENTIRE AGREEMENT. This License Agreement (including any addendum or amendment to this License
Agreement that is included with the Software Program) is the entire agreement between you and Lexmark
relating to the Software Program. Except as otherwise provided for herein, these terms and conditions
supersede all prior or contemporaneous oral or written communications, proposals, and representations
with respect to the Software Program or any other subject matter covered by this License Agreement (except
to the extent such extraneous terms do not conflict with the terms of this License Agreement, any other
written agreement signed by you and Lexmark relating to your Use of the Software Program). To the extent
any Lexmark policies or programs for support services conflict with the terms of this License Agreement,
the terms of this License Agreement shall control.
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